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1  How to start? 
1.1  How to Start ToupSky?  

1. Invoke the Windows metro start screen with keyboard button   , locate ToupSky 

 and click it to start the application(Win 8/10); 

2. Click the Start  button (At your screen bottom left corner) and a Start  menu will bring 

up. Move your mouse over the menu and try to locate ToupSky , click to start it (Win 

XP/7); 

3. Double click on the desktop icon “  ”  (If installed) to start ToupSky; 

1.2  How to start the camera? 

ToupSky will detect all of the cameras that your computer has i nstalled (Here, it is 

G3CMOS02300KPA , a 1.2M pixel USB2.0 CMOS guiding camera) and will list all  the 

camera names under the Camera List  group on the Camera Sidebar   

Click the Camera  Sidebar  (If it is not activated) and the Camera List to expand the 

Camera List  group (if not expanded).  

 

 

Click the camera name (Here it is G3CMOS02300KPA ) to start the video window and 

the camera will begin to stream the video. The video window will  be associated with a 

name called “Video [G3CMOS02300KPA] ”  (i.e., its title bar name will be “Video 

[G3CMOS02300KPA] ” ). 
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2  Video window GUI 
2.1  Video window GUI 

 

A:ToupSky; 

B: Menu; 

C:ToupSky toolbar; 

D: Camera  Sidebar  ; 

E: Folders Sidebar  ; 

F: Undo/Redo Sidebar  ; 

G: Histogram ; 
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H: Statusbar ; 

I: Auto Hide  button;  

J: Horizontal  ruler; 

K: Vertical  ruler; 

L: Camera Name;  

M: Frame Rate  and Frames  captured; 

N:Current Video  sizes; 

O:Current Temperature;  

AA: Title Bar right mouse button context menu; 

AB: Sidebar  right mouse button context menu; 

AC: Video  window right mouse button context menu; 

AD: Toolbar right mouse button context menu 

AE: Camera Sidebar  right mouse button context menu; 

AF: Horizontal Ruler  or Vertical Ruler  right mouse button context menu 

AG: Grids  submenu; 

AH: Double-click bring up Video Properties  dialog; 

AI: Double-clicking bring up Temperature  display style setup dialog;  

2.2  How to close the video window? 

1 Double-clicking the tabbed video window title or clickin g x on  will close the video 

window directly; 

2. Choose the Windows>Close All command to close the video window; 

3. Click the right mouse button on the video window title to invoke the context menu 

and choose Close  to close the video window; 

 

4. Press Ctrl+W . 
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3  Image window GUI 
3.1  Image window GUI 

 



Image window GUI 

5 

A:ToupSky; 

B: Menu; 

C:ToupSky toolbar 

D: Camera  Sidebar  ; 

E: Folders Sidebar  ; 

F: Undo/Redo Sidebar  ; 

G: Sidebar ; 

H: Statusbar ; 

I: Auto Hide  button;  

J: Horizontal  ruler; 

K: Vertical  ruler; 

L:The Opened file directory and name; 

M:Image file resolution; 

N:Image Zoom  ratio double-clicking will zoom the image to 100%; 

AA: Title Bar right mouse button context menu; 

AB: Sidebar  right mouse button context menu; 

AC: Video  window right mouse button context menu; 

AD: Toolbar right mouse button context menu; 

AE: Horizontal Ruler  or Vertical Ruler  right mouse button context menu; 

AF: Grids  submenu; 

AG: Double-click bring up Video Properties  dialog; 

AH: Double-click bring up  Scale Image  dialog;  

AI:  Zoom  ratio right mouse button context menu; 

3.2  How to close the image window? 

1. If you have modified an image before attempting to close it, double-clicking the 

tabbed image window title or clicking x on  will bring up a ToupSky  dialog: 

  

Clicking Yes will save the changes with its old name and close the window qui ckly, No 
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will close the file immediately with no changes and no warning,  or Cancel  will cancel 

the Close  command and leave the window there with no changes; 

2. If the Image  window is snapped from the video window and with number as its title, 

double-clicking the tabbed image window title or clicking x on  will bring up a 

warning ToupSky  dialog: 

 

Clicking Yes will bring up the Save As  dialog. 

  

In the Save As  dialog, choosing  

Save in : Select the driver and folder to which you want your image file saved in the 

Save in  combobox and enter the file name in the File name  edit box; 

Save : Click Save  to save the captured image with the specified directory and fi le 

name; 

Cancel : Click Cancel  to close the Save As  dialog and return to image window. 

Click No on the ToupSky dialog will close the file immediately with no changes and no 

warning. 
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Click Cancel  on the ToupSky dialog will cancel the Close  command and return to image 

window. 

3. Press Ctrl+W ; 

Choosing the Window>Close All  command can also close the tabbed image window. 

Please check the Window>Close All  for detail.
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4  UI toolbar 
When the camera is started or the image is opened (or captur ed), most of the icons on 

the toolbar will be enabled for the quick operation of t he video or image window. 

 

1: Open  (Ctrl + O); 

2: Save  (Ctrl + S); 

3: Quick Save  (Quick Save); 

4. Auto Capture (F7) 

5. Batch Record (F10) 

6: Zoom; (Ctrl+ or Ctrl-) 

7: Video/Image Select;   

8: Track (enabled only when the video/image size is larger than the wind ow size); 

9: Crosshairs  for the star alignment; 

10: Circle  for the star alignment; 

11: Circel with hole ; 

12: ST4 Test ; 

13: Previous Frame ; 

14: Next Frame ;  

15: Image Stitch ; 

16 �ÖPreferences  (Shift+P) 
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5  Camera Sidebar  

The Camera Sidebar  is used for the 

control of camera, it includes many 

group s (14). The group can be expanded 

by  a) clicking the group name or b) 

clicking  the Double Down Arrow  at the 

right  end of the group name. 

 

5.1  Camera List group 

 

Camera List  will list all of the cameras connected to the 

computer that support the ToupSky application. Click 

the camera name will start the camera video window. 

5.2  Capture & Resolution group 

 

Snap : Continuously Snap  images by clicking it; 

Record : Record  video stream with the supported 

format s; 

Resolution : Set the video resolution; 

Format : Video format, could be RGB or Raw format; 

Gain : If and only if the brightness is too low to meet the 

Exposure Time  up limit, drag the Gain  slide right until 

the video brightness is normal; 

Video Mode : The application will continuously display 

the video  in the Video  window; 

Auto Exposure : Uncheck the Auto Exposure  box to 

switch the Auto Exposure  mode to the Manual Exposure  

mode. The Exposure Target  slider will be disabled in this 

mode;  

When the Capture & Resolution group is expanded and 

the Auto Exposure  button is checked �Èa green rectangle 
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marked with “ Exposure ” will be overlaid on the video 

window.  This marked region is a reference region for 

judging if the image average brightness reaches to the 

Exposure Target  value. Drag the Exposure  ROI  to the 

dark er area will increase the video brightness and drag 

it to the brighter area will decrease the video brightness; 

Uncheck the Auto Exposure  box to switch the Auto 

Exposure  mode to the Manual Exposure  mode. The 

Exposure Target  slider will be disabled in this mode; 

Exposure Time : Drag the Exposure Time  slider to the left or right until the image 

brightness is normal; The exact Exposure Time  can also be entered by clicking the 

edit box  at the right end of the Exposure Time . This will bring up a dialog called 

Exposure Time . You can type the number in the field to set the exact Exposure Time  

value.  

Trigger Source: User can choose the Software  or Hardware  Trigger mode; 

Exposure Time : Can be set in h(hour), m (minute), s(second), ms (millisecond ) and 

us(microsecond); 

Single : Snap a single image to the Video  window(The Single  button will change to 

the Stop  button after it is clicked); 

Loop : Continuously snap the image to the Video  window until the Stop  button is 

clicked (The Loop  button will change to the Stop  button after it is clicked); 

Sequence : Snap a specified number of images to the separate Image  windows (The 

Sequence  button will change to the Stop  button after it is clicked) . After the process 

is finished or the Stop  button is clicked, the Sequence  capture will be stopp ed and 

the Stop  button will changed to the Sequence  button for the next clicking; 

Options : This button will invoke a Sequence Options  dialog and to set the Sequ ence 

Options  such as show the snapped imag e in the window or save it to disk. User can 

also choose the Directory  File prefix , File type  etc. for the image file to save.  

5.3  Color Balance group 

1. Click the color balance  bar to expand the color balance  group and a red rectang ular 

marked with white balance  will be overlaid on the video window; 

2.  Drag the red rectangle to a pure white or gray area and cl ick the white balance 

button to establish the video white balance for future video streaming process; 
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3. If the White Balance  automatic setting result and the 

actual one still has deviation, drag the Red, Green  or 

Blue  slides to the left or right to manually correct the 

White Balance . 

5.4  Color Adjustment group 

 

1. Hue : Adjusts the Hue  of the video . Drag the slider 

to the right to increase or drag to the left to decrease 

Hue; 

2. Saturation : Adjusts the Saturation  of the video. 

Drag the slider to the right to increase or drag to the 

left to decrease video Saturation ; 

3. Brightness : Adjusts the video  Brightness . Drag the 

slider to the right to increase or drag to the left to 

decrease the video Brightness ; 

4. Contrast : Adjusts the video  Contrast . Drag the slider to the right to increase or 

drag to the left to decrease the video Contrast ; 

5. Gamma : Adjusts the video  Gamma . Drag the slider to the right to increase or 

drag to the left to decrease the video Gamma ; 

6. Defaults : Click the Defaults  to clear all the changes and reset them to default 

ones ; 

7. All of your settings will be saved for future Color Adjustment  group. 

5.5  Frame Rate group 

 

Drag the slider to the r ight ( High ) to ensure that the 

camera can run the video at the fastest Frame Rate  

that the computer ’s USB hub supports. If the video 

fails  to display, drag the slider to the left ( Low ) to 

reduce  the Frame Rate  and this will enable the v ideo 

to stream in a low speed mode. 

5.6  Color/Gray group 
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If you wish to preview Color  video, choose the 

“Color ”  button, otherwise, choose the Gray  button. 

If you wish to preview Gray  video, check the “Gray ”  

button. 

5.7  Flip group 

 

If the video on the screen appears in different 

direction s from what is viewed under the camera, 

check the “Horizontal ”  or “Vertical ”  box to set the 

video  direction to the right one. 

5.8  Sampling group 

 

1. Bin : Pixel binning refers to the m ethod of 

combining (averaging ) pixels of blocks of 

ne ighboring same color pixels to resize the video to 

the lower resolution; 

2. Skip : Also called "Decimation", means that a certain amount of pixels  are not read 

out but skipped (horizontally, vertically or in both axe s). This reduces resolution of 

the resulting video but introduces subsampling artifacts. 

5.9  Bit Depth group 

 

Switch between 8 bits  and 12 bits . 8 bits  is the basic 

Windows image format. 12bits  will have highe r image 

quality but moderate frame rate speed . 

5.10  ROI group 

 

ROI , Region of interest. This function can set the ROI  

on the video window. When the ROI group was 

expanded, a dotted rectangle with "Handles" will 

appear around the video window that will let you alter the ROI . Use mouse button 

to adjust the ROI  size. If ROI  is ok, click Apply  will set the video to ROI  size, Defaults  

will return to the original one.  

5.11  Histogram group 

1. A Histogram  illustrates how pixels in an image are distributed by grap hing the 

number of pixels at e ach color intensity level. The Histogram  shows detail in the 

shadows (shown in the left part of the histogram), midtones  (shown in the middle), 
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and highl ights (shown in the right part). A Histogram  

can help you determine whether an image has 

enough d etail to make a good correction; 

2.  This group shows the Histogram  of current active 

video . Two vertical line markers show the upper and 

lower limits of the intensity levels. These markers 

can be dragged with mouse . If you are looking at a 

color image, the Histogram  will reflect the RGB(red, 

green and blue channels histogram at the same 

time) R(red), G(green), and B(blue) values with lines 

of the same color; 

3.  You can also enter directly the desired values in the Left  or Right  boxes below the 

Histogram  chart for both Left  and Right  Histogram  boundaries; 

4.  Click the �� Refresh ��  button to update the Histogram  display if the sample under 

observation is moved or changed; 

5. Clicking  the Defaults  button will return the Left  and Right  Histogram  boundaries 

to its original ones;  

6.  Click the Auto button to locate the two boundaries automatically to get the best 

video quality. 

5.12  Dark Field Correction 

 

To Enable  the Dark Field Correction , one should 

capture the dark field image first. After the images 

are captured, the Enable  button will be enabled. 

Check it will enable the Dark Field correction . 

Uncheck i t will disable the Dark Field Correction . 

5.13  Cooling group 

The Cooling group  is only available for those who have TE- cooling hardware inside 

the camera.  

TEC On: The Cooling will be enabled when this button is chosen;  

TEC Target : The final temperature value wished; 

TEC Off : The Cooling will be disabled when this button is chosen; 
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Fan On: Open the fan will accelerate the cooling 

speed;  

Fan Off : Stop the fan will lower the fan sound noise 

but decrease the cooling speed . 

5.14  Parameters group 

 

The Parameters  group is used to save the camera 

control parameters set for further application. 

Click Save  will save the current camera control 

parameters with new parameter f ile and then the Load  

and Overwrite  buttons will be enabled.  

Click Load  will load the saved camera control parameters; 

Click Overwrite  will overwrite the current camera control parameters to the cu rrent 

loaded active camera control parameters file;  

Click Management  will invoke a Management  dialog and in this dialog, o ne can 

manage all of the saved Parameter  files. 
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6  File 

6.1  Open Image •••     Ctrl+O 

Choose the File>Open Image ••• command to open an existing image file. The Open 

Image •••  command can also be used to preview an image in small size, o r to view its 

statistics and information without actually opening the imag e itself. These capabilities 

can be used to quickly locate a particular image. 

ToupSky supports and can open many image formats. These are ident ified in the Files 

of type  list box. 

 

More than one image can be opened within ToupSky simultaneou sly by a) with Ctrl + 

left mouse button method and b) Shift + left mouse button method  to highlight the 

files to be opened. In this mode, the Preview  window will be disabled. 

When opening an image, ToupSky places it into a new image wind ow. It then becomes 

the active window. 

Note : ToupSky maintains, at the File>Recent Files  submenus, a list of the last 4(Can 

be 1-8) opened files. Any of these files can be accessed by simply cl icking on file name. 
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If no files are listed in the File>Recent Files  submenu, the Open Image •••  command 

must be used to open the file. 

Also, the View>Browse(Ctrl+B)  command can be used to view images in an Icon  format 

under any selected directory. Brief information is given in the View>Browse menu. 

File name: From this list box, select the name of the file want to op en. Either the type 

of the file name (with its entire path, if it is not in th e current folder), or selecting Files 

of type  to obtain a list of File names . Double-clicking a file name in the large combo 

box (where both folder and file names are listed) will autom atically open it. 

Note : If just type in the File name , be sure that the Files of type  field correctly identify 

the format of the file to open. Otherwise error messages will br ing up when ToupSky 

tries to open the file. 

Files of type: In this list box, select the image format of the file to open. If one selects 

All supported formats , ToupSky uses the file's extension to identify its format. ToupS ky 

supports the following file formats: 

Window Bitmap(*.bmp,*.dib,*.rle) 

JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)  

Portable Network Graphics(*.png)  

Tag Image File Format(*.tif, *.tiff)  

Compuserve GIF (*.gif)  

PCX�Ä*.pcx �Å 

Targa(*.tga)  

PhotoShop(*.psd)  

ICON(*.ico)  

Enhanced Window Metafile(*.emf)  

Window Metafile(*.wmf)  

JBIG(*.jbg)  

Wireless Bitmap(*.wbmp)  

JPEG 2000 Standard(*.jp2) 

JPEG 2000 Codestream(*.j2k) 

Digital Negative (*.dng) 

Ser (*.ser) 
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Fits(*.fit;*.fits) 

If the image file does not use standard format-identifying ex tensions, the file in the File 

name  field must be typed, and then select its format from the Files of type list box. 

Otherwise, ToupSky will select a format based on the file name e xtension. 

Preview : Click this button to preview image in small size. In prev iew mode, statistics 

and information about the image (i.e. image Width, Height  and image location) will be 

displayed. The default is no Preview . 

Current File : Current File  location on your computer; 

Width : Current File  image width; 

Height : Current File  image height; 

6.2  Open Video •••    

The File>O pen Video•••  menu will be enabled only when there is no video file opened 

in the ToupSky frame or no camera was opened. 

1. Choose the File>O pen Video•••  command to open an existing video file; 

 

2. Select the name of the file you want to open. If the f ile does not appear, select the 

option for showing all files from the Files of Type  combobox. The video file type can be 

any one as shown below. 

 

3. Click Open  to open a video file, this will create a video window and beg in to start the 

video stream. The video window will be associated a name called “Video [XXX.XXX] ”  

(i.e., its title bar will display “Video [XXX.XXX] ”, here, XXX.XXX  is the video file name). 
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4. Click Cancel  to return to the application. 

Note : Only a single video can be opened at a time. ToupSky takes  camera as a special 

video file, if the camera was opened, this menu will be disabled  and the video file cannot 

be opened anymore. 

6.3  Save    Ctrl+S 

Choose the File>Save  command to immediately store the current window image to it s 

file (the file name is listed on the window's title bar) while l eaving the image still active 

in its window. 

If the image is untitled or titled with a digit, ToupSk y will issue the File>Save As •••  

dialog automatically. The default “Save as type ”  will be “Window Bitmap 

(*.bmp,*.dib,*.rle) ”. 

The File>Save  command can be used to save the most recent changes to disk. I t is 

often performed as a precautionary measure during lengthy or involved processes to 

reduce the amount of reprocessing that might be required in the event of a system 

failure or operational error. When an image is closed and  not to save its changes is 

chosen, ToupSky discards all changes made since the last File>Save  operation. 

Note : a).The File>Save  command always saves the contents of the entire window, even 

if there is an  AOI (Area of Interest)  defined on it; b).The File>Save  command will be 

disabled if the file is not changed or the changes have been saved.  

6.4  Save As •••  

Choose the File>Save As •••  command to store the contents of the current window to 

a specified file format. At the end of a File>Save As •••  operation, the image window 

will be associated with the new file and the new format (i.e. , its title bar will display the 

new file name). 

ToupSky supported file save formats are: 

Window Bitmap(*.bmp,*.dib,*.rle) 

JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif) 

Portable Network Graphics(*.png) 

Tag Image File Format(*.tif, *.tiff) 
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Compuserve GIF (*.gif) 

PCX(*.pcx) 

Targa(*.tga) 

JBIG(*.jbg) 

JPEG 2000 Standard(*.jp2) 

JPEG 2000 Codestream(*.j2k) 

Fits(*.fit) 

  

Save in : Find the folder where the file wishes to be saved. A n ew folder may be created 

using the New Folders  button; 

File name : The file name to be saved. To specify the file's location, eit her enter its entire 

path (disk and folder), or specify its location using the  Save in  list box; 

Save as type : In this list box, select the format in which the image wants t o be saved. 

Save As •••  is also used to convert a single image from one format to an other. For 

example, if a TIFF file needs to convert to PCX format, open the TIFF image first, then 

choose Save As •••  command with the PCX format to save it to a new file. 

The default “Save as type ”  will be “Window Bitmap (*.bmp,*.dib,*.rle) ”. The Save As  

command has several important uses beyond simply storing an  image to a new file 

name. Click Option  to select the different parameters to encode the file. 

6.4.1  Option for JPEG 

For JPEG (*.jpg,*.jpeg,*.jpe,*.jif,*.jfif) , Option  has the following items: 
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Image quality: If one save an image in JPEG format (*.jpg) , one may adjust image 

quality in the edit box. The values range from 0 to 100 . Default value: 75 ; 

Progressive: The default is unchecked; 

Optimize Huffman codes: The default is unchecked; 

Smoothing: The values range between 0 and  100 . Default value: 0; 

Save these setting as defaults: When saving a file, the current settings will be saved 

as defaults for the next file save operation. 

6.4.2  Option for PNG 

For Portable Network Graphics (*.png) , Option  has the following items: 

Interlaced: The default is unchecked; 

Save these setting as defaults: When saving a file, the current settings will be saved 

as defaults for the next file save operation. 
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6.4.3  Option for TIF 

For Tag Image File Format (*.tif, *.tiff) , the Option  has the following items:  

 

Appended pages: Determine whether the current image will be saved in multiple pag es 

style or not; 

Compressions: Specifies a method for compressing the composite image data. F or 

saving a 32 �; bit TIFF file, one can specify that the file be saved with predictor 

compression, but have no option to use JPEG compression. Predictor compression offers 

improved compression by rearranging floating point values, a nd works with both LZW 

and ZIP  compression; 

Image quality: If choosing Compressions as "JPEG" , the Image quality  can be adjusted 

by the slider bar. The values range between 0 and 100 . Default value: 75 ; 

Save these setting as defaults: When saving a file, the current settings will be saved 

as defaults for the next file save operation. 

6.4.4  Option for the other formats 

For Compuserve GIF (*.gif) ; PCX(*.pcx) ; Targa(*.tga) ; JBIG(*.jbg) ; FITS(*.fit)  there 

is no Option . 

Note : a) Detailed information of the above academic terminologi es can be found in 

books about image processing and image compression or internet; b ) The file saved 

directory can be restored for future use. To keep the directory  unchanged when 

ToupSky is started again, choose Options> Preferences•••  command, click Misc page 

and check Restore the current directory when startup  under the Privacy  item. 
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6.5  Batch Save •••  

The File>Batch Save •••  menu will be enabled when a) an image is opened; b)an image 

is captured from the camera; c)an image window is created by choosin g the File>Paste 

as New File  command; d)an image window is copied from the Undo/Redo Sidebar  with 

the copy button as show below: 

 

6.5.1  Batch Save for a) style image window 

If the image is modified, choosing the File>Batch Save •••  command  will save the file 

with its opened file name and file extension; 

6.5.2  Batch Save for b), c) or d) style image window 

If the image window has been created with b), c) or d) style, c hoosing the File>Save 

As•••  command to realize the file saving task will be time-consuming.  The Batch 

Save•••  command will runs File> Save As•••  command with the name automatically 

specified according to the paradigm specified in the Batch Save  dialog  

To start the File>Batch Save•••  command for b) style image window, you have to  

1. Start the camera; 

2. Snap at least an image first; 

3. Choosing the File>Batch Save•••  command will bring up a Batch Save  dialog: 
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Directory : Enter the name of the drive and directory where your captur ed images will 

be saved. You may either type the path information, or use t he Browse  button to locate 

it from a standard Browse Folder  dialog. 

Name Format : The year , month , date , hour , minute  and second  or nnnn(sequence)  are 

used to as part of the file name. If more files are saved wit h in a second, a (xx)  suffix 

is attached to the end of Name Format  to avoid the possible name conflict. For the 

nnnn(sequence)  “Name Format ”, no suffix is needed. 

File Prefix : Enter a file name prefix for Batch Save  when generating files names for a 

series of images. This prefix will be combined with Name Format  to form a final file 

name naming paradigm. 

File Type : In this combobox, select the format you want the image to  be saved (can be 

BMP, JPG, PNG, TIF, FIT ). The parameters for encoding the file (For BMP or FIT format , 

there is no options). See Options> Preferences•••> File page, choosing the file format 

line and click Config•••  button for more details. Or check the Options>Preference>File  

in Sec.14.1.4 

Sample : The final file name is shown at the right of the Sample  label for reference. 

4. If the setting in the Batch Save  dialog was finished, click OK button to begin the file 

batch save process or Cancel  to cancel the Batch Save  command and return to the 

application. 

For the c) or d) style image window, only steps 3 and 4 a re needed. 

Note : a) In the process of the File> Batch Save•••  command, the title on the image tab 

or image window will be modified with the file name paradig m in the Batch Save  dialog. 

b) The File>Batch Save•••  will perform no saving operation if the file is not mod ified or 
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unchanged. 

6.6  Paste as New File 

The File>Paste as New File  menu will be enabled only when there is valid image data 

on the clipboard first (see the Edit>Copy  menu). If there is no image data on the 

clipboard, the File>Paste as New File  menu will be disabled. 

Choose the File>Paste as New File  command to place the contents of the clipboard 

image into a new image window, which becomes the active window. 

The new image type will be the same as that of the original image.  ToupSky will accept 

image data from other applications via the clipboard as lon g as it is in Windows Bitmap 

(DIB)  format. 

Note : ToupSky will assign a digit to the  Paste as New File  command created image 

window ’s title bar. 

6.7  Recent Files 

ToupSky maintains 4 (default) most recently opened document files under the Recent 

Files menu. Choosing one of these submenus will reopen that file i mmediately. 

Note . a) The maximum number of  Recent Files  can be modified by choosing the 

Options> Preferences•••  command and clicking the Misc page as shown below: 

 
Here, clicking the 4 (default) edit box will allow you to enter the number of  the Recent 

Files  submenus that you want. The value ranges from 0 to 8, the default is  4 ; b) One 

can also check the Clear the Recent Files when exit the application  to clear the  Recent 
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Files  after exit ToupSky application. 

6.8  Exit 

Choosing the File>Exit  command will close the video window, all of the image windo ws 

and the Browse  window. After all of the windows are closed, ToupSky will end itself. 

Note : If an image has been modified before attempting to Exit  it, ToupSky will issue a 

warning to ask if user want to save the image or not fi rst. 

 

If multiple images have been modified before attempting to Exit  it, ToupSky will issue 

Save Files  dialog to direct the user to save changes in different ways. 

 

See Window>Close All for details.
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7  Edit 

7.1  Cut    Ctrl+X 

The Edit>Cut menu will be enabled only when image file(s) in the Browse  window is 

(are) selected. 

7.1.1  Cut for the Browse window selected files 

When the Browse  window is active and the image files in the browse window are  

selected, the Edit>Cut command will be enabled. Choosing the Edit>Cut command will 

copy it to the clipboard. After the file(s) is(are) pasted, the file(s) will be deleted.  

Note : The Edit>Cut  command does not support image Cut  operation in ToupSky. 

7.2  Copy    Ctrl+C 

7.2.1  Copy the selected area to the clipboard 

In the video window or image window, choose the Edit>Copy  command to Copy  an 

video or image's selected area to the clipboard. 

Note : When an image ROI is selected, the Edit>Copy  menu will be enabled. 

7.2.2  Copy for the Browse window selected files to the clipboard 

When the Browse  window is active and the image files in the Browse  window are 

selected, the Edit>copy command will be enabled. Choosing the Edit>Copy command 

will then copy them to the clipboard. 

Note : The copied files on the clipboard can be pasted into the Browse  window by 

choosing the Edit>Paste  or Browse>Paste shortcut  command. 

7.3  Paste    Ctrl+V 

If there is (are) image file(s) on the clipboard and the curren t active window is the 

Browse  window, the Edit>Paste  menu will be enabled. 

7.3.1  Paste the clipboard files to the Browse window 

When the Browse  window is active and the image files in the Browse  window are 

selected, the Edit>Paste command will be enabled. Choosing the Edit>Paste command 

will paste the clipboard files to the Browse  window. 
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Note : The Edit>Paste  command does not support the image area Paste  operation. 

7.4  Paste Shortcut 

This command is for the Browse  window only. This menu will be enabled when files in 

the Browse  window are selected and the Edit>Copy  command is executed to copy the 

file shortcut to the clipboard. Choose this command will create t he clipboard files 

Shortcut (in *.lnk format) in the current Browse  window directory. 

If the to be pasted *.lnk file has been existed in the cur rent Browse  window, ToupSky 

will pop up a prompt dialog. 

 
One can click Yes, No or Cancel  to overwrite, abort or  cancel the command. 

7.5  Delete    Delete 

The Browse>Delete File  menu will be enabled if the file(s) is (are) highlighted in th e 

Browse  window. This command is for the Browse  window only. 

You can Delete  or remove one or more files from the Browse  window. The steps are as 

follows: 

7.5.1  For Browse Window file delete 

1. Select one or more files by a) Clicking the displayed file  icons, a single file will be 

highlighted; b) Clicking the file one by one with Ctrl + left mouse button , all of the 

clicked files will be highlighted; c) Clicking the displayed fi le icons, the first clicked file 

will be highlighted, clicking the end file with Shift + left mouse button , all of the files 

among the first and last will be highlighted. d) Dragging t he mouse to draw a dotted 

line rectangle across the files you wish to delete, all of the f iles in the rectangle will be 

highlighted; e) Ctrl+A  to select whole files in the Browse  window. 

2. a) Press the Delete  key to delete the selected files; b) Click you right mouse butto n 

to bring up a context menu, choose the Delete  command to delete the highlighted files. 
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A Confirm File Delete  dialog will bring up. 

In the Confirm File Delete  dialog, click Yes to move the files to the desktop recycle bin, 

or No to cancel the Delete  operation. 

7.6  Image Select   

The Edit>Image Select  command can be used to mark ROI  and Copy  the selected ROI  

to the clipboard. This command is only used to select the i mage ROI . 

Choosing the Edit>Image Select  command will check this menu (or click  on the 

toolbar will keep  down) and the cursor will turn into “ ” . The ROI selection steps 

are described as below: 

1. After the Edit>Image Select  command is chosen, drag the mouse cursor across the 

image with the left button held down until the area is selected; 

2. Release the left button and the area will be marked. Hand les will appear on the area 

edge that will allow altering the selection after it is marke d. 

7.7  Select All  Ctrl+A 

7.7.1  Select all on the video/image window 

When the video/image window is active, choosing the Select All command will select 

all  pixels on the video/image within the canvas (shortcut: Ctrl+A ). 

7.7.2  Select all files in the Browse window 

When the Browse  window is active, choosing the Edit>Select All  command will select 

all of the files in the Browse  window under the specified directory in the Folders Sidebar . 

7.8  Select None  Ctrl+D 

Deselect a) any selected area ( ROI ) on the image; b) the file listed in the Browse  

window. 

7.8.1  Select None for video/image ROI 

When a video or image area is selected, the Select None menu will be enabled. Choosing 

the Edit>Select None  command will delete the dotted rectangle representing the 
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selected area ( ROI ). 

7.8.2  Select None for Browse window 

When the Browse  window is active and the image files in the browse window are  

selected, the Edit>Select None  command will be enabled. Choosing the Edit>Select 

None  command will deselect all of the selected files in the Browse  window.
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8  View 

8.1  Browse    Ctrl+B 

8.1.1  Open the Browse window 

1. Choose the View>Browse  menu or click the Browse  toolbar button  will open or 

active browse images under the specified directory in the Folders Sidebar ; 

2. Click the Folders Sidebar  to activate it and double-clicking the listed directory in the 

Folders Sidebar  will create the Browse  window. 

After creating the Browse  window, ToupSky will display a Browse  window that looks like 

windows explorer. The child window on the left part of the Browse  window called Folders 

Sidebar  is used to locate the directory on the hard disk. Images in th e current directory 

are displayed in Large Icons  or Small Icons  mode on the right side of the Browse  window. 

Image file’s order  can be set in Ascending  or Descending  order according to Sort  by 

Name , Type , Size , Width or Height et al. 

8.1.2  Browse window right mouse button context menu 

Clicking the right mouse button on the listed Icon  in the Browse  window will bring up a 

right mouse button context menu as shown below: 

 

These context menu functions are described in 

Edit>Cut  

Edit>Copy 

Edit>Paste 

Browse  >Sort>Sort by Names 

Browse  >Sort>Sort by Type 

Browse >Sort>Sort by Size  

Process>Stitch  
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Edit>Paste 

Shortcut  

Edit>Delete  

Browse  >Sort>Sort by Width 

Browse  >Sort>Sort by Height 

Browse  >Sort>Ascending 

Browse  >Sort>Descending 

Browse  >Icon>Large Icons 

Browse  >Icon>Small Icons 

Browse  >Refresh 

Browse >Properties  

menus. Please check them for details. 

Note : The Folders Sidebar  and the Browse  can be used to perform tasks such as 

creating new folders, renaming, moving, and deleting files. Ind ividual file information 

and import data from digital cameras can also be displayed.  Double-clicking the left 

mouse button on the icon will open the image as an active i mage in full size. See Image 

window GUI  in Sec.3 for more details. 

8.2  Sidebar 

There are 3 Sidebars  in the ToupSky frame window in tabbed style. They are Camera 

Sidebar , Folders Sidebar  and Undo/Redo Sidebar . 

8.2.1  Sidebar overview 

 
AA: Camera Sidebar ; 

AB: Camera Sidebar  groups for the control of the camera. 
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BA: Folders Sidebar ;  

BB: Back  to the previous folder; 

BC: Forward  to the next folder; 

BD: Browsing  the pictures under the application’s file  directory; 

BE: Open the Browse  window if it is not opened (Double-clicking on the selected  

directory will perform the same functions.); 

BF: Folders  to locate the Browse  window ’s file directory. 

CA: Undo/Redo  Sidebar ; 

CB: Forward to the previous step; 

CC: Backward to the next step; 

CD: Operation Copy : Copy the highlighted operation in the Undo/Redo  Sidebar  to a new 

image window; User can also drag the selected operation in the Undo/Redo  Sidebar  to 

the window area to create a new image window; 

CE: Remove  the highlighted operations from the Undo/Redo  list (This button will be 

enabled only when the operation(s) is (are) selected, the opene d image(the first 

operation) cannot be removed; 

CF: Indicating the Current  operation displayed in the image window; 

CG: Operation  Index ; 

CH: Operation  name. 

8.2.2  Sidebar>Camera 

The Camera Sidebar  is mainly used for the control of camera, it includes man y groups. 

Each group can be expanded by clicking the group name or the arrow button at the 

right of the group name. 

Checking the Sidebar>Camera  menu will activate/show it on sidebar group. 

Please check Camera Sidebar  in Sec.5 for details. 

8.2.3  Sidebar>Folders 

The Folders Sidebar  is mainly used for the image Browse  control. 

Checking the View  >Sidebar>Folders  menu will activate/show the Folders Sidebar . 

Clicking its tree can navigate the file directories. 

Double-clicking the directory in the Folders  will create the Browse  window. If there are 
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image files under the directory that ToupSky supports to Browse , the image files will 

be displayed in Large  or Small  icons mode. 

Their orders can be set in Ascending  or Descending  styles according to Sort  by Name , 

Type , Size , Width or Height et al. 

Clicking the right mouse button on the directory will bring  up the right mouse context 

menu as shown below: 

  

This is the basic window explorer menu and will not be explained in this manual. 

8.2.4  Sidebar>Undo/Redo 

The Undo/Redo Sidebar  is used to list the Undo/Redo  operations for the Image  and 

Process  menus ’ command. 

Checking the View>Sidebar>Undo/Redo  menu will activate/show the Undo/Redo 

Sidebar . 

8.3  Grid 

The Grid  menu has 5 submenus, they are: 

8.3.1  Settings•••    

Choosing the View> Grid>Setting•••  command, or choosing the Preference>•••  
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command and clicking the Grids  page realize the same function. 

Choosing the Option> Preference>•••  command and clicking the Grids  page can set the 

Grid Style , Line Style , and Line Color  for the Grid  overlaid on the video and image 

window can also be set. 

Style : The Grid Style  can be No Grid , Auto Grid  or Manual Grid . Default is No Grid ; 

Line Style : The Line Style  for the grid can be Solid , Dash , Dot  or DashDot  et al. Default 

is Solid ; 

Color : The color of the grid line. Default is Red (255,0,0). 

 
8.3.2  Grids>No Grids 

Choosing this command will remove both Manual Grids  and Auto Grids  overlaid on the 

video/image window. 

8.3.3  Grids>Auto Grids 

Choose Grids>Auto Grids  command to overlay the grids on the video/image 

automatically. 

The Auto Grids can be set in the View>Grids>Setting •••  menu. 

8.3.4  Grids>Manual Grids 

Choosing this command will display two small Right Arrow and Down Arrow overlaid on 

the top of the Vertical Ruler and on the left of the Horizontal Ruler  as shown below: 

Down Arrow : Move the mouse over the Down Arrow  will show a horizontal drag icon. 

Drag the Down Arrow  along the Horizontal Ruler  to where ever you want. When it is 
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dragging over the video/image, there will be a Vertical  line appeared to let you judge 

where to release this line on the video/image. You can drag any lines to overlay them 

on the video/image. 

The overlaid lines can be adjusted by dragging the specific Down Arrow  again on 

Horizontal Ruler . 

Right Arrow : Move the mouse over the Right Arrow  will show a vertical drag icon . Drag 

the Right Arrow  along the Horizontal Ruler  to where ever you want. When it is dragging 

over the video/image, there will be a Horizontal  line appeared to let you judge where 

to release this line on the video/image. You can drag any lines t o overlay them on the 

video/image. 

 
The overlaid lines can be adjusted by dragging the specific Right Arrow  again on Vertical 

Ruler . 

Choose the Grids>No Grid  command to remove the Manual Grids  overlaid on the 

video/image window. The menu will be checked. 

Choose the Grids>Manual Grids  command again (If it is unchecked) to display all the 

previous Manual Grids  overlaid on the video/image window. The menu will be checked . 

8.3.5  Grids>Remove All Grids 

Remove (Delete) all of the Manual Grids  or Auto Grids  overlaid on the image/video 

window. 

8.4  Best Fit  Num * 

Choose View>Best Fit  command to automatically resize the video/image to fit in the 
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window. 

Note : Choosing this command will enable View>Actual Size  menu. 

8.5  Actual Size  Num / 

Note : This option will be disabled if the image is currently v iewed at 100%. At any other 

zoom ratio, View>Actual Size  will be enabled. 

Choose View>Actual Size command to set the active image to its Actual Size  (e.g. 

100%). 

8.6  Full Screen    ESC 

Choosing the View>Full Screen  command will display the video window in full screen 

style. Press the ESC button will restore the video window. 

8.7  Track   

Note : If the video/image size is smaller than the window size. The track operation will 

be disabled. 

If the image's actual size is larger than the video/image win dow, check this command 

to position the video/image that does not fit entirely wi thin in the video/image window. 

Its function is similar to the scroll bars. It is an altern ative to using the arrows on the 

scroll bars for positioning the video/image within the windo w. 

Checking the View>Track  menu will change the cursor to  and the button on the 

toolbar will be checked. 

Then keep down the mouse button to drag the region of interest  on the video/image to 

any location in the video/image window. 

8.8  Crosshairs 

Display the Crosshairs  to locate the star in the video window. Click the left mous e 

button on the video window to move the Crosshairs  to wherever interested. 
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8.9  Circle 

Display the Circle to locate the star in the video window. Click the left mouse button on 

the video window to move the Circle  to wherever interested. 

 

8.1  Circle with Hole 

Display the Circle with Hole to locate the star in the video window. Click the left mouse  

button on the video window to move the Circle with Hole  to wherever interested. 
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9  Browse 
9.1  Sort 

9.1.1  Sort>Sort by Names 

This command is for the Browse  window only. 

Sort the image files in order of names in the Browse  window. 

9.1.2  Sort>Sort by Type 

This command is for the Browse  window only. 

Sort the image files in order of file type in the Browse  window. 

9.1.3  Sort>Sort by Size  

This command is for the Browse  window only. 

Sort the image files in order of file size in the Browse  window. 

9.1.4  Sort>Sort by Width 

This command is for the Browse  window only. 

Sort the image files in order of image file width in the Browse  window. 

9.1.5  Sort>Sort by Height 

This command is for the Browse  window only. 

Sort the image files in order of image file height in the Browse  window. 

9.1.6  Sort>Ascending   

This command is for the Browse  window only. 

Sort the image files in order of the Ascending  mode (i.e. 1, 2, 3 and 4) in the Browse  

window. 

9.1.7  Sort>Descending   

This command is for the Browse  window only. 

Sort the image files in order of the Descending  mode (i.e. 4, 3, 2 and 1) in the Browse  

window. 
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The Sort settings are saved until they are changed. For example, if you sort images in 

the Browse  window according to the Type , the images will remain sorted according to 

Type  until the Sort settings are changed. 

9.2  Icon 

9.2.1  Icon>Large Icons   

This command is for the Browse  window only. 

The Thumbnail  mode displays small preview images; you can select different vie w 

modes in the Browse  window. 

Choosing the Icons>Large Icons  will display the image files in Large Icon  mode in the 

Browse  window. 

9.2.2  Icon>Small Icons   

This command is for the Browse  window only. 

The Thumbnail  mode displays small preview images; you can select different vie w 

modes in the Browse  window. 

Choosing the Icons>Small Icons  will display the image files in Small Icon  mode in the 

Browse  window. 

9.3  Refresh   F5 

This command is for the Browse  window only. 

If the files under the Folders Sidebar ’s directory are altered outside of ToupSky, after 

switch back to ToupSky, one can Refresh  the image files in the current directory to 

update the Thumbnails  with Browse>Refresh  command. 

9.4  Properties •••    

If an image file listed in the Browse  window is highlighted. Choosing the 

Browse  >Properties  command or clicking the selected file in the Browse  window with 

the right mouse button context menu Properties  will bring up a Properties  dialog as 
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shown below: 

 

   
The file Properties  dialog including 3 pages. They are General , Security  and Details  

pages. These Property pages may depend on the operating system and we will not 

discuss it in this help manual. 
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10  Setup  

10.1  Start/Pause     Pause 

If the video in video window is playing, one can choose the Setup>Start/Pause  

command to pause the video and choose the Setup>Start/Pause  command again to 

start the video again. 

10.2  View Properties •••   Shift+V 

The Setup>View Property •••  will help you to understand the camera hardware 

statistical properties. Choose the Setup>View Property •••  command to invoke the View 

Property  dialog as below: 

 

The items in the dialog are described in the following: 

Device Name: Readable string to identify the name of the camera device; 

Pixel Size : The current camera pixel size; 

Still Image Capture: To identify whether or not the camera supports Still Image Capture . 

Still Image Capture  is used for high resolution camera to capture an image with a 

different resolution from the video. This feature is mainly used  to capture high 

resolution image under low resolution video to compromise bet ween the frame speed 

and the image resolution; 

Video Width: The actual video window video width; 

Video Height: The actual video window video height; 

10.3  ST4 Test 

The Setup>ST4  Test command will invoke a ST4 dialog for the test of the guiding 

camera’ s ST4 port. Click the arrow key to test if it is OK. The c entral edit box can input 
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the time for the test. 
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11  Capture 

11.1  Capture Image    F8 

During the video preview, you can always choose the Capture>Image Capture  

command to capture the video image. 

After the image is captured, the captured image will become the curr ent active window. 

The Capture>Capture Image  menu will be disabled. If you wish to capture image again, 

click the video window title to activate the video window an d the Capture>Capture 

Image menu will be enabled again. 

Note : a) The “Snap ”  button  on the Camera Sidebar  can continuously snap 

the image even if the video window is not activated. User can cli ck this button on the 

Camera Sidebar  to capture image in quick style ; b) Only when the video window is 

active, the Capture>Capture Image  menu will be enabled; c) If the Live  and Snap  

resolutions are different, ToupSky need to switch the resoluti on from Live  to Snap  

resolution in the backstage to capture an image with Snap  resolution. After the Snap  

is finished, ToupSky will switch back to the Live  resolution to continus the video stream 

process. This will take more time to capture a still image.  

11.2  Auto Capture    F7 

Choosing the “Capture>Auto Capture ”  command or press the toolbar button  will 

begin to capture the image from the video stream automatically.  

After begin to capture, the “Capture>Auto Capture ”  will changed to “Capture>Stop 

Capture ”  and the toolbar button  will be checked. 

Choosing the “Capture>Stop Capture ”  command or press the checked toolbar button 

 will stop the auto capture process. 

The “Capture>Stop Capture ”  menu will changed to “Capture>Auto Capture ”  and the 
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toolbar button  will be unchecked. 

The Auto Capture  command needs to define some predefined parameters. This can be 

done in Options> Preferences•••> Auto Capture  property page: 

 

Directory : Enter the name of the drive and directory where the new i mage will be saved. 

You may either type the path information, or use the Browse  button  to locate it 

from a standard Browse Folder  dialog; 

Name Format : The year , month , date , hour , minute  and second  or nnnn(sequence)  are 

used as part of the file name. If more files are saved with  in a second, a (xx)  suffix is 

attached to the end of Name Format  to avoid the possible name confliction. For the 

nnnn(sequence)  Name Format , no suffix is needed. 

File Prefix : Enter a file name prefix for Auto Capture  when generating files names for a 

series of images. This prefix will be combined with Name Format  to form a final file 

name according to the naming paradigm. 

File Type : In this combobox, select the format in which you want the i mage to be saved 

(can be BMP, JPG, PNG, TIF, FIT); 

Sample : The final file name is shown at the right of the Sample  label for reference; 

Capture every frame : Check this item will capture every frame in the video sequence; 

Time Slot(second) : Capture an image according to the time interval to (0 -100S, default 
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is 6); 

Total Images : Checking Total Images  will enable its edit box. You can enter the Total 

Images  (1-9999, the default is 100) to be captured. ToupSky will stop the Auto Capture 

process automatically when the Total Images  are reached; 

If Total Images  is unchecked, ToupSky will capture the images continuously unt il user 

choose the Capture>Stop Capture  command again to stop the Auto Capture process. 

After the Auto Capture  is started, the Capture>Auto Capture  menu will be changed to 

the Capture>Stop Capture)  menu. Choosing this command will stop the Auto Capture  

process. 

There are a variety of image format available (they are bmp , jpg , png, tif or fit ) to save 

the captured image. For example, when choosing jpg  format, the save options can be 

set in Options> Preferences•••> File  property page. If the format has options need to 

be define, the Config•••  button will be enable.  

 
Clicking the Config•••  button will pop up a dialog as bellow. Different format  has 

different options. 

After all the parameters are set. Click OK will close the dialog and the parameters can 

be used for the Auto Capture  command with no further setup to accelerate the capture 

process. 
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11.3  Start Record    F9 

This command will begin to record the video according to th e setup in 

Options>Preference>Record  property page (See Sec.14.1.1) 

 

1.  You can a) choose the Capture>Start Record •••  command; b) click “Record ”  button 

 on the Camera Sidebar  ; c) use the shortcut key “F9”  to start recording 

movies.  

2.  After the video record  is started. The  button on the Camera Sidebar  

will become . Clicking  will stop the capture process, 

otherwise, it will stop untill the Time Limit  in Options>Preference>Record page  is 
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reached. After the video record process is finished. The  on th e 

Camera Sidebar  will become  again for the future Record  process; 

User can choose the File>Open Video •••  command to display the captured video file in 

the video window; 

After the Capture>Start Record  is in the process, the Capture>Batch Record  or the 

Batch Record  button on the toolbar will be disabled. 

11.4  Batch Record    (F10) 

Begin to record the video in batch mode. This command will all ow the user to record 

the video in a quick way. The Batch Record  parameters is defined in the 

Options> Preferences•••> Record and  Options> Preferences•••> Batch Record property 

pages (See Sec.14.1.1 and 14.1.2) for details. 

 
After the Batch Record  is begin, the application will begin to record the 1 st video until 

the stop condition is reached (see Options> Preferences•••> Record ). 

Then after the Time interval  is reached in the Options> Preferences•••> Batch Record 

page, the application will begin to record the 2 nd or the next video. 

The Batch Record  will stop until the Number  is reached in the Options> Preferences•••>  

Batch Record page. 
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After the Batch Record  is begin, the Capture>Start Record  menu will changed to 

Capture>Stop Record  menu (The  button on the Camera Sidebar  will 

change to ) and the Batch Record  menu and toolbar button will be 

disabled. User can choose Capture>Stop Record  menu or click the  button 

to stop the current recording process.  

Note, this command will not stop the Batch Record  process, after the condition of the 

Time interval  in the Options> Preferences•••>Batch Record page is reached, the 

application will begin to record the next frame until th e Number  in the 

Options> Preferences•••> Batch Record page is reached. 

To stop the whole Batch Record  process, only when the previous record is stopped or 

finished and the next record does not begin, in this interv al, the will be enable, 

click it will stop the whole Batch Record  process. 
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12  Image 
12.1  Mode 

12.1.1  Color Quantize •••  

The Color Quantize •••  command is widely used to change the image bit. ToupSky 

supports the mutual changes among 24 bit , 8 bit , 4bit  or 1 bit  images. 

When the Colour Bits  dialog is opened, the 

default checked color bit s is the current imag e's 

color bit. Check the desired bit and click OK to 

end the command. The image will converted to 

the selected color bits in the image window.  
12.1.2  Gray Scale 

Choose the Gray Scale  command to convert a color image (true color image or in dex 

color image) to a gray scale image. If the original image is 24 bit, the new image is 8 

bit. Otherwise the bits of the image will not be modified. 

12.1.3  Contrast Preserving Decolorization 

Choose the Image>mode>Contrast Preserving Decolorization  command can convert 

the color image into gray image with contrast preserved. The following pictures (a) is 

the original microscopic image, (b) is the gray image produ ced by traditional method, 

(c) is the gray image produced by Contrast Preserving Decolor ization. 

 

(a) Original microscopic image 

   

(b) Traditional method    (c) Contrast Preserving Decolorization 

12.2  Adjust 
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12.2.1  Brightness/Contrast •••  

The Image>Adjustment> Brightness/Contrast•••  command offers simple adjustments 

to the tonal range of an image. This command makes the same adjustment to every 

pixel in the image. The Brightness/Contrast  command does not work with individual 

channels and is not recommended for high-end output because it can result in the loss 

of details about the image. 

 

Brightness : Dragging the slider bar to the left decreases the level and  dragging it to 

the right increases the level. The numbers on the right of th e slider bar displays the 

Brightness  value. Values can range from -100  to +100 . Default is 0; 

Contrast : Dragging the slider bar to the left decreases the level and dr agging it to the 

right increases the level. The numbers on the right of the slider bar displays the 

Contrast  value. Values can range from -100  to +100 . Default is 0; 

12.2.2  Color •••  

Choose the Image>Adjustment> Color•••  command to modify the overall mixture of 

the colors in an image. 

There are four color modules: RGB, CMYK, HIS  and HLS. 

 
RGB: ToupSky uses the RGB model. It assigns an intensity value to each pixel ranging 

from 0 (black) to 255 (white) for each of the RGB components in a color image. 

For example, a bright red color might have an R value of 246, a G value of 20, and a B 

value of 50. When the values of all three components are  equal, the result is a shade 

of neutral gray. When the value of all components is 255, th e result is pure white; when 
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the value is 0, pure black. 

RGB images use 3 channels to reproduce up to 16.7 million colors o n-screen. In addition 

to being the default mode for new ToupSky images, the RGB mode is used by computer 

monitors to display colors. This means that when working in color modes other than 

RGB, such as CMYK, ToupSky uses RGB mode for display on-screen. 

Although RGB is a standard color mode, the exact range of colors represe nted can vary, 

depending on the application or display device. 

CMYK: The CMYK mode is based on the light-absorbing quality of ink p rinted on papers. 

As white light strikes translucent inks, certain visible wavel engths are absorbed while 

others are reflected back to the eyes. 

  
In theory, pure cyan ( C), magenta ( M), and yellow ( Y) pigments should combine to 

absorb all light and produce black. For this reason these col ors are called subtractive 

colors. Because all printing inks contain some impurities, these th ree inks actually 

produce a muddy brown and must be combined with black ( K) ink to produce a true 

black. ( K is used instead of B to avoid confusion with blue.) Combin ing these inks to 

reproduce color is called four-color process printing. 

The subtractive ( CMY) and additive ( RGB) colors are complementary colors. Each pair 

of subtractive colors creates an additive color, and vice vers a. 

HSI: Based on the human perception of color, the HSI  model describes 3 fundamental 

characteristics of colors: 
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Hue  is the color reflected from or transmitted through an object . It is measured as a 

location on the standard color wheel, expressed as a degree betw een 0°  and 360° . In 

common use, Hue  is identified by the name of the color such as red, oran ge, or green. 

Saturation , sometimes called chroma, is the strength or purity of the color . Saturation  

represents the amount of gray in proportion to the hue, measured as a percentage from 

0% (gray) to 100% (fully saturated). On the standard color  wheel, Saturation  increases 

from the center to the edge.  

Intensity  is the relative lightness or darkness of the color, usually measured as a 

percentage from 0%  (black) to 100%  (white). 

HLS: The HLS model is very similar to the HLS color model. The main difference 

between them is the calculation used to produce the brightness value.  In the HLS model, 

a pixel's brightness ( L) is derived from its three ( R, G and B) color values. In the HLS 

model, a pixel's brightness ( L) is determined by the minimum and maximum values of 

its three color values. 

 
The values beside the slider bar show the color changes in vari ous color channels. 

For RGB channel values, they are range from -100  to +100 . Default is 0; 

For CMYK channel values, they are range from -100  to +100 . Default is 0; 

For HSI  channel values, the H value can range from -180  to 180 , the S value is range 
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from -275  to 275 , and the I  value is range from -442  to 442 .Default is 0; 

For HLS channel values, the H value is range from -180  to 180 , the L value is range 

from -100  to 100 , and the S value is range from -100  to 100 . Default is 0; 

12.2.3  HMS •••  

Choose the Image>Adjustment>HMS •••  command to adjust the HL (Highlight), M 

(Midtone), and S(Shadow) parts of the image. Each part's value ranges from -100  to 

100 . This command is only available for 24 bits true color image. 

 

12.2.4  Curve •••  

Choose the Image>Adjust> Curve•••  command to adjust the entire tonal range of an 

image. But instead of making adjustments using only three variables (Highlight , 

Midtone , Shadow ), one can adjust any point on the curve along a 0-255 scal e while 

keeping up to any other values constant. One can also use Curve  to make precise 

adjustments for individual color channels on an image. The Curve  dialog is shown below: 

 

Horizontal Axis: The horizontal axis of the graph represents the original in tensity values 

of the pixels ( Input  levels). 

Vertical Axis: The vertical axis represents the new color values ( Output  levels). In the 
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default diagonal line, all of the pixels have identical Input  and Output  values.  

Curve area: Area (specified with the blue rectangle ) to setup a map between input and 

output; 

a) When you open the Curve  dialog you see, perhaps surprisingly, not a curve but 

a straight line. As a default, the input values are the sam e as the output, so there’s 

no change; 

b) By clicking in the center of the line and dragging upw ards, we make our first 

curve. Raising the curve increases the overall brightness of the scene. 

c) Conversely, clicking in the center and dragging downward s lowers the brightness, 

producing an image th at’s darker overall ; 

d) As well as clicking in the center, we can also adjust the endpoints. Clicking the 

top right point and dragging down limits the brightest pa rt of the image, reducing 

contrast. 

e) If we drag that top right point to the left rather th an down, we produce the 

opposite effect —increasing the contrast of the image. This is a very useful and  

controllable quick fix; 

f) By dragging the top and bottom points towards the c enter, we create a stylized, 

posterized effect that turns any photograph into more of  a graphic object. 

g) Click once in the center of the RGB curve to "pin" that midpoint; now drag just 

the top half of the curve to make this S shape, and the result i s to increase the 

overall contrast. 

h) You can add up to any control points to the curve, lock ing those values. To 

remove a control point, 1)drag it off the graph or 2) click the right mouse button 

on that point. You cannot delete the endpoints of the curve.  

a) b) c) d) 
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e)  f) g) h) 

Grid: Check to overlay the grid on the Curve  window; 

Channel : To adjust the color balance of the image, check the channel( R, G or 

B) from the Channel  button. Check the white button to select RGB channels at the same 

time, which is located on the left of the R (Red), G (Green) and B (Blue) buttons; 

Curve : Click the Curve  with your left mouse button, a spline curve (straight lin e) 

will setup the initial input-output relation. Click on t he Curve  will mark the Curve  with 

a point. The point number can be any as long as it can be in serted on the Curve . Drag 

the marked point  until the image looks satisfactory. The point can be delet ed by move 

the mouse on it and click the right mouse button on it.  

Pencil : Check the pencil button at the bottom of the dialog, and  use your left mouse 

button to draw a new arbitrary Curve in the  Curve  area. 

Reset: Click the Reset  button will reset the Curve  to the initial straight line. 

Apply: Apply current Curve  map on the image. 

12.2.5  Filter Color •••  

Choose the Image>Adjustment>Filter Color  command to filter a special color channel 

from a color image. Check either Red, or Green,  or Blue  color to filter. For every pixel, 

if check Red color to filter, only information about the red channel will be discarded, 

and Green  and Blue  information will remain there. 

 

See Image> Extract Color•••  for another color operation. 

12.2.6  Extract Color •••  
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Choose the Image>Adjustment> Extract Color•••  command to extract a special color 

channel from a color image. Check either Red or Green,  or Blue  color to extract.  

For every pixel, if selecting Red color to extract, only information about the red chann el 

will be kept, and Green  and Blue  information will be discarded. 

 

See Image> Filter Color•••  for another color operation. 

12.2.7  Invert 

Choose the Image>Adjustment>Invert  command to reverse the pixel values of the 

active image without going through the lookup table. 

12.2.8  Edge Preserving Smooth •••  

Edge Preserving Smooth  is an image processing technique that smooth away textures 

whilst retaining sharp edges. Examples are the Bilateral filter, t he Guided filter and 

Anisotropic diffusion. 

Choose the Image>Adjust>Edge Preserving Smooth •••  command can smooth the 

entire image and preserve the edge of image, as shown below: 

 
Edge Preserving Smooth  function provide two kinds of filter including Recursive  and 

Normalized Convolution  filter, and the default filter is Recursive .  

ToupSky use Spatial Sigma  and Range Sigma to define the filter kernel size. The big ger 

the two parameters, the stronger the image smoothed, vice versa. 
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12.2.9  Detail Enhance •••  

Choose the Image>Adjust>Detail Enhance•••  command can enhance the detail in the 

image, as shown below: 

 

ToupSky choose Spatial Sigma  and Range Sigma  to define the kernal size of detail 

enhance algorithm. The bigger the 2 parameters, the stronger t he enhanced image and 

vice versa. 

The following picture is the detail enhanced image for reference with  default parameter. 

       

a)Original image and b)Enhanced image 

12.3  Rotate 

Choose the Image>Rotate  command to rotate the entire image. One has the following 

submenus: 

12.3.1  90(CW) 

Rotate the image clockwise by a quarter-turn. 

12.3.2  180(CW) 

Rotate the image clockwise by 180 degrees. 
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12.3.3  270(CW) 

Rotate the image clockwise by 270 degrees. 

12.3.4  Arbitrary•••  

Rotate the image by a specified angle. If choosing this opti on, enter an angle between 

0 and 360 degrees in the angle text box, and check CW or CCW to rotate clockwise or 

counterclockwise. For the Arbitrary•••  operation, it will invoke an Image Rotate  dialog 

like below: 

 

Degree : The degree that the image to be rotated. 

CW: Rotates the image clockwise. 

CCW: Rotates the image counterclockwise. 

Quality : One can select one of the three methods for the image rotation amon g Nearest 

Neighbor , Bilinear,  and Bicubic . The default is Bilinear . 

12.3.5  Flip Horizontal   

Reverses the image in the application area so that the top rig ht corner of the original 

image is now the top left, and the top left corner of the original image is now the top 

right corner. 

12.3.6  Flip Vertical    

Reverses the image in the application area so that the top rig ht corner of the original 

image is now the bottom right corner, and the top left corn er of the original image is 

now the bottom left corner. 

12.4  Crop    Shift+C  

Choose the Image>Crop  command to remove the portions of an image that does not 
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want so that the focus is on the part of the image that i s left. This document instructs 

users on how to Crop  an image in ToupSky. 

1. Choose the Open Image•••  command to open an image to Crop ; 

2. Choose the Edit> Image Select command or click the Image Select  button  on 

the Toolbar , the cursor will change to a small cross. 

3. Move the cursor over the image to the desired location, cl ick the mouse button and 

hold it down to mark the first position. 

4. Drag the mouse over the part of the image to be kept, a dotted rectangle appears 

around the selection and release the left mouse button. 

5. Optional 1 : To move the rectangle: a) Move the mouse over the selected area and 

when it becomes a move cursor, click and hold the left mouse butto n;b) Drag the 

selected area to the desired position. 

 

6. Optional 2 : To change the size of the rectangle: a) Put the mouse cursor on one of 

the handles that appear on the edges of the selected area; b) Cli ck and hold the mouse 

button; c) Drag the box to the desired size. 

Note : Each of the handles that appear on the edges of the box si zes the box differently. 

7. To Crop  the image, choose the Image>Crop  command or press Shift+C  buttons. 

Note : If the selected area is on the video, choosing the Image>Crop  command will 
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capture the selected area and display it on a new image window.  

12.5  Image Scale •••    

Choose the Image>Image Scale •••  command to change the image to a specified size. 

This process actually changes spatial resolution by adding (replicating) or removing 

(decimating) pixels to achieve the specified dimensions. 

Width  and Height : When choosing the  Image Scale  command; the dialog displays the 

dimensions of the original image in pixels. The Width  and the Height  can be set on the 

new image by adding or removing pixels. If Constrain Proportions  is checked, the Width  

and Height  will stay proportionate to each other. If Constrain Proportions  is unchecked, 

the Width  and the Height  can set independently, but this will distort the image. 

 

Reset : Reset the image Width  and Height  to the original ones. 

Constrain Proportions : To maintain the current proportions of pixel Width  and Height , 

check Constrain Proportions . This option automatically updates the Width  as the Height  

is modified, and vice versa. Otherwise, uncheck the Constrain Proportions  button. 

Scale method : There are 3 options for the Scale method . They are: Nearest Neighbor , 

Bilinear , and Bicubic . The default is Bilinear . 

12.6  Histogram •••     Shift+H 

A Histogram  illustrates how pixels in an image are distributed by graphi ng the number 

of pixels at each color intensity level. The Histogram  shows whether the image contains 

enough detail in the Shadows  (shown in the left part of the Histogram ), Midtones  

(shown in the middle), and Highlights  (shown in the right part) in order to make a good 

correction. 

The Histogram  also gives a quick picture of the tonal range of the imag e, or the image 
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key type. A low-key image has detail concentrated in the sh adows, a high-key image 

has detail concentrated in the highlights, and an average-k ey image has detail 

concentrated in the Midtones . An image with a full tonal range has a number of pixels 

in all areas. Identifying the tonal range helps determine the appropriate tonal 

corrections. 

Choose the Image> Histogram•••  command to open the Histogram  dialog as shown 

below. 

Depending on the image’s color mode, choose R, G and  B, or Luminosity  to view a 

composite Histogram  of all the channels. 

If the image is RGB true color, choose Luminosity  to display a Histogram  representing 

the luminance or intensity values of the composite channel. 

  

  

If the image is RGB true color, choose R, G and  B to display a composite Histogram  of 

the individual color channels in color. 

Do one of the following: 

To view information about a specific pixel value, place the mouse pointer in the 

Histogram . 
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To view information about a range of values, click down the  left mouse button and drag 

it in the Histogram  to highlight the range. 

The dialog displays the following statistical information b elow the Histogram : 

Pixels : Represents the total number of pixels used to calculate the Histogram . 

Level : Displays the intensity level of the area underneath the poin ter. 

Count : Shows the total number of pixels corresponding to the int ensity level underneath 

the pointer. 

Percentile : Displays the cumulative number of pixels at or below the level underneath 

the pointer. This value is expressed as a percentage of a ll of the pixels in the image, 

from 0%  at the far left to 100%  at the far right.
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13  Process 

13.1  Stitch •••     Shift+T 

Image stitching or photo stitching is the process of combinin g multiple photographic 

images with overlapping fields of view to produce a segmented panorama or high-

resolution image. Commonly performed through the use of comput er software, most 

approaches to image stitching require nearly exact overlaps bet ween images and 

identical exposures to produce seamless results. Some digital camer as can stitch their 

photos internally. Image stitching is widely used in today’s world in applications such 

as “Image Stabilization” feature in camcorders which  use frame-rate image alignment, 

high resolution photo mosaics in digital maps and satellite p hotos, medical imaging, 

multiple image super-resolution, video stitching and object inser tion. 

ToupSky also integrated this function into it. It includ es Video Stitch , Image Stitch and 

Browse Window Stitch . 

13.1.1  Video Stitch 

When the video window is active, choosing the Process>Stitch •••  command will invoke 

the video Stitch  dialog as below: 

Capture Images 

 

Snap: Click to capture image from camera. One should try to move the slide to a prop 

position to capture the desired images. In the moving proc ess, the next image should 

have some overlaid area with the previous left or up image to ensure the success of 

the stitching process. 
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Reset: When an image or images is or are captured, the Reset  button will be enabled, 

click Reset  will remove it or them from the memory �× It will be disabled when there is 

no captured image;  

Snap: The captured images from the camera; 

Cancel: Click to cancel the stitching process; 

Next> : Click Next>  will step to the next step; 

Finish : Click Finish  will accept the other Default setup and begin to stitch the captu red 

images according to the above setup. 

Stitching Method 

 

Panorama Straighten : The image stitching direction. It can be Horizontal , Vertical  and 

None . Default is Horizontal; 

Projection Type : For image segments that have been taken from the same point i n 

space, stitched images can be arranged using one of various map projections. ToupSky 

including Plane , Cylindrical , Spherical , Fisheye , Stereographic , Mercator  or Transverse 

Mercator map projections. The Default is Cylindrical ; 

Seam Finder : Seam Finder method, ToupSky including None , Voronoi Diagram , Graph 

Cut Color  or Graph Cut Color Grad . Default is Graph Cut Color ; 

Exposure Compensation : Exposure Compensation  is required between images to 

minimize exposure differences. ToupSky including None , Gain  or Blocks Gain Exposure 
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Compensation method. Default is Blocks Gain ; 

Bundle Adjust : Bundle Adjustment can be defined as the problem of simultaneousl y 

refining the 3D coordinates describing the scene geometry as wel l as the parameters 

of the relative motion and the optical characteristics of the camer a(s) employed to 

acquire the images, according to an optimality criterion invo lving the corresponding 

image projections of all points. ToupSky including Ray adjust  or Reprojection error 

adjust method. Default is Ray adjust ; 

<Back : Click <Back  will return to the previous setup page; 

Next>: Click Next>  will step to the next step;  

Finish : Click Finish  will accept the other Default setup and begin to stitch imag es 

according to the above setup; 

Cancel: Click to cancel the stitching process; 

Stitching Parameter 

 

Match Confidence : 1~100, Default is 65; 

Panorama Confidence : 1~100, Default is 100; 

Match Strength : 0~100, Default is 25; 

Blend Strength : 0~100, Defaults is 5; 

Defaults : Click Defaults  will set all the parameters to the Default  ones. 
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<Back: Click <Back will return to the previous step; 

Finish : Click Finish  will begin to stitch images according to the above setup. Af ter the 

Finish button is clicked, ToupSky will start to stitch and a progress dialog will be shown 

to indicate the progress of the process. 

Cancel: Click to cancel the stitching process; 

 

The final stitched image will be created in a new image window.  

 

In the stitched image, there are some black areas; these are happen ed when there are 

translations among the edge images in both directions. 

13.1.2  Image Stitch 

If images are opened in ToupSky, for example 0001.jpg, 00 02.jpg, 0003.jpg, 0004.jpg 

are opened as shown below: 
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Choosing the Process>Stitch  command will invoke the image Stitch  dialog as shown 

below: 

 

a) Available Images and b) Selected Images 

Available Images: The images opened by ToupSky �× Here, 4 images are listed in the list 

box. One can click the image file name to select the files to be  added to the Selected 

Images; 

Selected Images: The images selected for stitching �× Using Add>>  to add the Available 

Images to this list box; 

Add>>: When an image or images is or are selected and highlighted in the Available 

Images  window, the Add>>  will be enabled. Click Add>>  will add it or them into the 

Selected Images  list box �×  

Add All>>: Click Add All>>  will add all of the Available Images  into the Selected Images  

list box; 
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Remove: When an image or images is or are selected and highlighted in  the Selected 

Images  list box, the Remove  button will be enabled, click Remove  will remove it or 

them from the Selected Images  list box �×  

Clear: Used to clear all of the images in the Selected Images  list box. When no image 

in the Selected Images  list box, it will be disabled �×  

Cancel: Click to cancel the stitching process; 

Finish : Click Finish  will accept the other Default setup and begin to stitch the captu red 

images according to the above setup; 

Next> : Click Next>  will step to the next step; 

The other Next>  steps are just the same as those of the Video Stitch  process. 

The final stitched image will be created in a new image window a s shown below: 

 

The Stitched image 

In the stitched image, there are some black areas; these are happen ed when there are 

translations among the edge images in both directions. 

13.1.3  Browse Window Stitch 

Click the Folders Sidebar to activate it. Double-click the right directory to show the  

images under the directory in the Browse  window. Choosing the image files to be 
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stitched and then clicking the right mouse button will display the context menu, choose 

the Stitch  submenu to start the image stitch operation (One can also choo sing 

Process>Stitch  to do the same operation after the files are selected in th e Browse  

window) 

After the Stitch  command is selected, a dialog called Stitch  will pop up as shown below.  

 

The Stitch  dialog and the other Next>  steps are just the same as those of Video Stitch . 

The final stitched image will look like below: 

In the stitched image, there are some black areas; these are happen ed when there are 

translations among the edge images in both directions. 

 



Process 

70 

The stitched image 

13.1  Denoise 

ToupSky provides 3 types of noise removal methods, Adaptive Wiener Filter , Bilateral 

Filter , Non Local Means . The processing speed of the 3 methods is from fast to slow , 

and the denoising quality is getting better and better. Each method is described in detail 

in the following: 

13.1.1  Adaptive Wiener Filter 

The Adaptive Wiener Filter  can preserve more image details than those of median filter, 

mean filter, Gauss filter. The effect is more remarkable for add itive noise (such as 

Gaussian noise) and multiplicative noise (such as Poisson noise).   

For the Adaptive Wiener Filter  algorithm, please find the details in the relevant 

literatures, here only to illustrate the improvement of Ada ptive Wiener Filter over the 

classical Wiener filter.  

In the classical Wiener filter, the image noise intensity requir es the user to manually 

input, but it is difficult to accurately enter the accurate v alue even for experienced users, 

because the value is usually very small, such as 0.0036781. Th erefore in the 

development of the Adaptive Wiener Filter , the noise level is automatically calculated 

according to the image mean variance. 

The process is quite simple, open an image, choose the Process>Denoise>Adaptive 

Wiener Filter to denoise the image. 

13.1.2  Bilaternal Filter •••  

The Bilateral Filter  is a nonlinear filtering method that considers image spatial  proximity, 

pixel value similarity, image spatial information and g ray level similarity to achieve the 

purpose of edge preserving denoising. The Bilateral Filter  has the simple, non-iterative, 

local characteristics. The Bilateral Filter  is good to preserve image edge compare with 

Wiener filter or Gauss filter. 

Choosing Process>Denoise>Bilateral Filter •••  will pop-up dialog called Bilateral Filter  

as shown below: 
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Value domain : the range of neighborhood pixel in radius for consideri ng, the greater 

the value, the slower process speed. 

Space domain : Sigma value, the higher the value, the more effective the denoi sing 

effect. 

13.1.3  Non Local Means •••  

The traditional local mean filter is a pixels average metho d around the target pixel, but 

the Non Local Means is a weighted average method to average all of the image patches 

over the search window. The weight is determined according to  the similarity between 

the target patch and neighborhood patches in the search window . 

Compared to other famous denoising algorithms, such as Gau ssian, Wiener filter, total 

variation and wavelet denoising, The Non Local Means method can get better effect. 

Choosing Process>Denoise>Non Local Means •••  will pop-up dialog called Non Local 

Means  as shown below: 

 

Strength : The denoising strength, the greater the value, the more removal  the image 

noise, but will lose more details; 

Template Window : The template block size, used to calculate the weight, the 
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recommended default value is 7; 

Search Window : The template patch search window size, used to calculate the weighted  

average value among image patches. Large value will increase the  processing time. The 

recommended default value is 21. 

13.1  Sharpen 

13.1.1  USM •••  

UnSharp Masking (USM) is an image sharpening technique, often available in digi tal 

image processing software. The "unsharp" of the name derives fro m the fact that the 

technique uses a blurred, or "unsharp", positive image to creat e a mask of the original 

image. The unsharped mask is then combined with the negative image, creating an 

image that is less blurry than the original one. 

Open an image and then choose Process>Sharpen>USM •••  command, a dialog will pop 

up as below. 

 

Radius : Affects the size of the edges to be enhanced, so a smaller radius enhances 

smaller-scale detail. Higher Radius values can cause halos at the edg es. As a result, 

fine detail needs a smaller Radius. In addition, Radius an d Amount interact; reducing 

one allows more of the other. 

Threshold:  Controls the minimum brightness change that will be sharpen ed. This 

parameter is important to prevent smooth areas from becoming speckled. The 

threshold setting can be used to sharpen more-pronounced edges, while leaving subtler 

edges untouched. Low values should sharpen more because fewer areas are excluded. 

Higher threshold values exclude areas of lower contrast. 

Amount:  is listed as a percentage, and controls the magnitude of each ov ershoot (how 

much darker and how much lighter the edge borders become). Thi s can also be thought 
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of as how much contrast is added at the edges. It does not af fect the width of the edge 

rims. 

  

a) Original image; b) Sharpened image 

13.1.2   Laplacian Sharpen 

The Laplacian  operator is an example of a second derivative method of  enhancement. 

It is particularly good at finding the fine detail in an  image. Any feature with a sharp 

discontinuity (like noise, unfortunately) will be enhanced by  a Laplacian  operator. Thus, 

one application of a Laplacian  operator is to restore fine detail to an image which ha s 

been smoothed to remove noise. 

Open an image and then choose Process>Sharpen>Laplacian Sharpen , no parameter 

is required for this method. 

 

a) Original image; b) Sharpened image 

13.1  Color Toning 

13.1.1  Gamma •••    

The Process>Color Toning>Gamma •••  measures the brightness of midtone values 
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produced by a device (often a monitor). A higher gamma valu e yields an overall darker 

image.  

 

Preview : Check this button to display the real-time effects when one cha nges the slider 

bar’s position.  Default is checked; 

Gamma : Dragging the slider bar to the left decreases the level, while m oving it to the 

right increases the level. Values can range from 0 to 3.0 . Default is 1.0. 

13.1.2  Histogram Equalization •••   Shift+Q 

Adaptive histogram equalization (AHE) is a computer image proces sing technique used 

to improve contrast in images. It differs from ordinary hist ogram equalization (HE) in 

the respect that the adaptive method computes several histograms, each corresponding 

to a distinct section of the image, and uses them to redistrib ute the lightness values of 

the image. It is therefore suitable for improving the local con trast. However, AHE has a 

tendency to over amplify noise in relatively homogeneous regions o f an image. A variant 

of adaptive histogram equalization called contrast limited a daptive histogram 

equalization ( CLAHE) prevents this by limiting the amplification. 

Please open an image and then choose Process>Color Toning >Histogram 

Equalization ••• , a dialog should pop up as follows. 

 

Strength : The Strength  will affect the enhancement effect. The larger the value, the 

more obvious the effect. 
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a) Original image; b) Enhanced image 

13.1.3  LCC•••  

The Local Color Correction algorithm is computed in two steps: 

A mask image is computed from the input image. 

The mask image is computed from the intensity component of th e color image, defined 

as the average of R, G and B values i.e. I=(R+G+B)/3. The use of i ntensity information 

avoids distortions of the chroma. The mask image is obtained by inverting and then 

blurring the intensity component of the input image. 

The input and mask images are combined to get the result. 

The combination operation consists of a power function, whe re the exponent is 

computed using the mask value previously found. If the mask va lue is greater than 128, 

it will result in an exponent less than 1, while if the mask v alue is lower than 128, it 

will result in an exponent greater than 1. Moreover, if th e mask value is precisely 128, 

the exponent will be 1, and it will have no effect on the inpu t image. The operation is 

equivalent to a pixel-wise gamma correction. 

Please open an image and then choose Process>Color Toning >LCC ••• , a dialog should 

pop up as follows. 
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Strength �ÖThe strength will affect the enhancement effect. The larger the value, the 

more obvious the effect. Range:1~100, default is 50. 

 

a) Original image; b) Enhanced image 

13.1.4  AMSR 

There are limited dynamic range problems when real world scenes are ca ptured from a 

digital camera and displayed on monitors. Tone mapping a lgorithms are applied to 

image processing to reduce the dynamic range of an image to  be displayed on low 

dynamic range devices. Multi-scale Retinex is one of the most p opular methods for 

dynamic range compression, color constancy and color renditi on. Here, we improve its 

performance by adopting the adaptive weight functions, named Adaptive Multi-scale 

Retinex (AMSR).  

Please open an image and then choose Process>Color Toning>AMSR , the a) Original 

image; b) Enhanced image 

   

a) Original image; b) Enhanced image 

13.2  Deinterlace 

Deinterlacing is the process of converting interlaced image o r video, such as interlace 

sensor into a non-interlaced form. 
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13.3  Filter •••   Shift+I 

Choose the Process>Filter •••  command to apply one of ToupSky's numerous filters on 

the active image. If you are not familiar with the process and  effects of filtering, some 

discussions about spatial filtering should be reviewed. Toup Sky provides an extensive 

set of convolution and no convolution (morphological) filt ers. You can also create 

custom filter kernels and apply them with the Filter  commands. 

Choosing the Process>Filter •••  command will open the Filter  dialog. Each group of 

filters has its own property page or tab, where the Filter  type and size can be selected. 

The filtered results are almost always written to the active i mage. The Edit>Undo  

command can be used to remove Filter  operations that have been applied. 

13.3.1  Image Enhance 

  

Low Pass: Check this filter to soften an image by eliminating high-fr equency information 

(this has the effect of blurring sharp edges). The Low Pass filter replaces the center 

pixel with the mean value in its neighborhood. The Low Pass filter can also be used to 

remove noise. 

High Pass: Check this filter to enhance high-frequency information. The High Pass  filter 

replaces the center pixel with a convolved value that significant ly increases its contrast 

from its neighbors. The High Pass  filter leaves only elements of high contrast. 

Gauss: Check this filter to soften an image by eliminating high-fr equency information 

using a Gauss  function. This has the effect of blurring sharp edges. The operation of 

the Gauss  filter is similar to the Low Pass filter, but it degrades the image less than 

the Low Pass filter. 
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High Gauss: Check this filter to enhance fine details. This operation is similar to the 

unsharp masking technique (see the Sharpen filter), but it int roduces less noise into 

the image. It uses a Gaussian curve type of kernel. Available in  7x7 and 9x9 kernel 

sizes. 

Equaliza-tion: This filter is used to enhance the contrast based on the hist ogram of 

the local neighborhood (See Option  below). 

Sharpness: Check this filter to enhance fine details, or refocus an image t hat is 

blurred. The sharpen filter sharpens the image using the uns harp masking technique. 

Median: Check this filter to remove impulse noise from an image. The Median  filter 

replaces the center pixel with the Median  value in its neighborhood. It will also blur 

the image. 

Rank: Check this filter to remove impulse noise from an image. The  pixels in the 

kernel are ranked by order of intensity, and the pixel in  that range at the rank 

percentage is chosen for comparison. For example, in a 5x5 ker nel, there are 25 

pixels. A rank percentage of 95% would choose second-brightest  pixel for 

comparison. If the difference between the selected pixel and the center  pixel is 

greater than the threshold value, the Rank  filter replaces the value of the center pixel 

with the value of the selected pixel. 

Option : 1. If one of the Enhancement  filters is checked, the following options will be 

displayed: 

3 x 3: Check 3 x 3  kernel will produce a more subtle filtering effect. 

5 x 5: Check 5 x 5  kernel will produce a moderate filtering effect. 

7 x 7: Check 7 x 7  kernel will produces a more extreme filtering effect. 

Passes: Set the filter applied times on the image. When a filter is a pplied multiple 

times, its effect is amplified by each pass. An image that has been so ftened by 

one pass of the Low Pass  filter will be softened further by a second pass. 

Strength: Enter an applied value from 1-10 that reflects how much of the filtering 

effect on the image. 

A value of 10 specifies the full strength (100%) of the fi ltered result applied to each 
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pixel. Values less than 10 cut the full weight of the filt er. 

A value of 1 indicates that only 10% of the difference between the filtered pixel 

value and the original pixel value should be applied, a v alue of 2 indicates that 

20% of the difference should be applied, and so forth. 

Rank: This value specifies which pixel in the sorted array will be u sed to replace 

the center pixel. Pixels in the array will be sorted in ascending  order. The pixels are 

indexed from 0 to Kernel  Size  x Kernel  Size-1. In the pixel index 0 corresponds to 

the lowest pixel value. 

The Rank  will be specified in terms of a percentage of the indexes ( Kernel Size  x 

Kernel Size -1). A 50% Rank  means the middle of the array. 0% rank means the 

lowest index (lowest gray value), and 100% rank means the hi ghest index 

(highest gray value). 

Option:  2. If the Equalization  filter is checked, the options will relate to the histogram  

equalization. Local Histogram Equalization  modifies the contrast of an image based on 

the pixel values in a small window surrounding each pixel. 

Window: Image pixels statistics (min, max, histogram, mean, standard devi ation, 

etc.) will be calculated on a small Window of the image. These measurements are 

then used to derive the local contrast for that area of the  image. In short, an area 

of Window x Window  around each pixel is all that is considered when modifying 

the intensities in the image. Larger Window produces smoother results, while 

small Window track small details more closely. 

Best Fit: Choose the Best Fit  button to optimize the values for the particular 

image. The results are achieved by stretching the local histogram to maximize the 

contrast between the brightest and darkest pixels in the loca l window region. 

Linear: This option distributes the histogram linearly across the inten sity scale. 

This function produces a high contrast image with the highest  possible dynamic 

range. 

Logarithmic: This option concentrates the histogram at the low end of the scale. 

This function produces a high contrast image with little dyn amic image. It will 

tend to darken the image overall. It is useful for increasing  the contrast in a very 
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light image. 

Exponen-tial: This option concentrates the histogram at the high end of the scale. 

This function produces a high contrast image with little dyn amic image. It will 

tend to lighten the image overall. It is useful for increasing t he contrast in a very 

dark image. 

13.3.2  Edge Enhance 

 

Sobel : Check this filter to enhance just the principal edges in an image.  The Sobel  

applies a mathematical formula to a 3x3 neighborhood to locate and highlight its 

edges. 

Roberts: Check this filter to enhance fine edges in an image. The Roberts  filter is not 

a convolution filter. It applies a mathematical formula upon a 4 x 4 neighborhood to 

produce its effect. The upper left pixel in the neighborhood  is the one that is replaced. 

Sculpt: Check this filter to apply a sculpted effect on the image. 

Horizontal: Check this filter to detect and emphasize horizontal edges. 

Vertical: Check this filter to detect and emphasize vertical edges. 

Options : 1. If one of the Edge  filters has been checked, the options will relate to kernel 

size and filtering strength. The following options will be d isplayed: 

3 x 3: Check 3x3 kernels to produce a more subtle filtering effect. 

5 x 5: Check 5x5 kernels to produce a moderate filtering effect. 

7 x 7: Check 7x7 kernels to produce a more extreme filtering effect.  
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Passes: Enter the number of times that the filter will be applied to the image. 

When a filter is applied multiple times, its effect is amplified  by each pass. An 

image that has been softened by one pass of the Image Enhancement Filter , will 

be softened further by a second pass.  

Strength: Enter a value from 1-10 that reflects how much of the filt ering effect to 

apply to the image. A value of 10 specifies that the full strength (100%) of the 

filtered result will be applied to each pixel. Values less than 10 cut the full weight 

of the filter - a value of 1 indicates that only 10% of th e difference between the 

filtered pixel value and the original pixel value should be  applied, a value of 2 

indicates that 20% of the difference should be applied, and so forth. 

Option  2. If Sobel  or Roberts  is checked, no options are available. 

13.3.3  Morphological 

 

Erode: Check this morphological filter if one wants to modify t he size of objects in the 

image. The Erode filter erodes the edges of bright objects an d enlarges the edges of 

dark ones. 

Dilate: Check this morphological filter if one wants to modify t he size of objects in the 

image. The Dilation filter dilates bright objects and erodes dark ones.  

Open: Check this morphological filter if one wants to modify the shape of objects in 

the image. Assuming the image contains bright objects on a dark  field, the Open filter 

will smooth object contours, separate narrowly connected objects, and remove small 

dark holes.  
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Close: Check this morphological filter if one wants to modify t he shape of the objects 

in the image. Assuming the image contains bright objects on a d ark field; the Close  

filter will fill gaps and enlarge protrusions to connect ob jects that are close together.  

Tophat: Check this filter to detect and emphasize points, or grains, th at are brighter 

than the background. There are 3 kernel sizes for this proc essing. Click the radio 

button to change the kernel size to the value that most closel y matches the size of 

the grains to detect. 

Well: Check this filter to detect and emphasize points, or grains, that are darker than 

the background. There are 3 kernel sizes for this processing. C lick the radio button to 

change the kernel size to the value that most closely matches the si ze of the grains to 

detect. 

Gradient: Check this filter to enhance edges in an image. 

Watershed: Check this filter to separate objects that are touching. The Watershed 

filter erodes objects until they disappear, then dilates them a gain, but will not allow 

them to touch. The Watershed filter will not operate upon Tru e Color images. If one 

wants to separate objects in a True Color image, he must fir st convert it to Gray Scale  

(see Process Frame: Image>Gray Scale ). 

Thinning: Check this filter to reduce an image to its skeleton. When choo sing this 

filter, one must set the threshold that determines whether a pixel  is part of the 

subject or part of the background (see Options below). The Th inning filter will not 

operate upon True Color images. If one wants to thin a True Color  image, he must 

first convert it to Gray Scale .  

Distance: The distance filter is used to show the distances of pixels with in blobs to the 

outer boundaries of those blobs. After applying the dista nce filter, the background will 

be black (i.e. pixels with value 0). Only the area within t he blobs will have non-zero 

values (will be white). The values of each pixel within the blob will be a count of the 

shortest distance from that pixel to the edge of the blob. Th us, all pixels along the 

blob's border will have a value of 1 (since they are one pi xel away from the edge of 

the blob); pixels that are a distance of 2 from the bord er will have the value 2, and so 

on. This creates a distance map of the image. The Distance  filter will not operate 

upon True Color  images. If one wants to use the Distance  filter with a True Color  
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image, he must first convert it to Gray Scale . 

Options 1. If Erode , Dilate , Open , or Close  filters is checked, the options will relate to 

the kernel size and shape. The following options will be presen ted: 

2 x 2 Square: Check to use the 2x2 square kernel configurations. 

3 x 1 Row : Check to use the 3x1 row kernel configuration.  

1 x 3 Column : Check to use the 1x3 column kernel configuration. 

3 x 3 Cross : Check to use the 3x3 cross kernel configuration. 

5 x 5 Circle : Check to use the 5x5 circular kernel configurations. 

7 x 7 Circle : Check to use the 7x7 circular kernel configurations. This is a two-

pass filter, accomplished using a 5 x 5 circle followed by a 3x3 cross.  

11 x 11 Circle : Check to use the 11 x 11 circular kernel configurations. Th is is a 

three-pass filter, accomplished using a 5 x 5 circle follo wed by another 5 x 5 

circle, followed by a 3 x 3 cross.  

Passes: Set the number of times iterate the filter. 

Note : The circular kernels are especially effective on round objects (cel ls, grains and so 

on) because their circular configuration preserves the circular shape of the objects 

better than square configurations. 

Option  2. If the Tophat , Well , or Gradient  filter is selected, the options will relate to 

kernel size and shape. The following options will be presente d: 

3 x 3: Check to use the 3x3 square kernel configurations. 

5 x 5: Check to use the 5x5 square kernel configurations. 

7 x 7: Check to use the 7x7 square kernel configurations. 

Option  3. If Watershed , Thinning , or Distance  filter is checked, the options will relate 

to the threshold. The following option will be presented: 

Threshold: Enter a percentage value from 1-100 that specifies the intensit y value 

to binarize the image. For example, a Threshold of 50% on a Gray Scale  image 

would set all values !127 to 0 (black) and all values "12 8 to the maximum value 

for that image class (white). 

13.3.4  Kernel 
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The Kernel  page allows edit the kernel files for the morphological and  convolution filters. 

 

Note : The HiPass, LowPass , Laplacian  and Unsharp kernel files are used by the HiPass, 

LowPass , Laplacian , and Sharpen  options listed in the Image Enhancement Filters  page 

dialog window (i.e. there is no difference between selecting one o f these kernel files 

and selecting its Option  button in the Filter  window -- the 2 methods ultimately do the 

same thing). Because these kernel files are essential to the operat ion of these filtering 

options, they must not be deleted or renamed. 

Filter type: Check to modify the kernel for a selected Filter type , either Convolution  or 

Morphological  filters. 

Edit••• :  Invoke the Edit  Kernel dialog to modify the selected filter kernel. 

Name••• : This combobox contains the name of the selected kernel file. If  one 

wants to save the modified kernel file to the same file, leave  it as it is. If one 

wants to save the file to a new location, enter the new filena me here. 

Kernel Size : Click the spin buttons or enter the number to change the siz e of the 

kernel. Either direction may take into account one to nine pix els. As one modifies 

the Kernel Size , the shape of the kernel representation changes accordingly. In 

the center of the dialog, there are white boxes containing co efficients that will be 

multiplied with each pixel that will be taken into account by  the filter kernel. One 

can change any coefficient by clicking on it and adjust it a s desired. 

Fill : Click this button to fill every element of the kernel with  a particular value. 

The Fill kernel dialog appears. One may enter a value between 0 and 10. Using 
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the Fill button is useful for setting all coefficients to  the same value. One may 

then change the coefficients that require a different value. 

Offset : The pixel whose value is being modified is usually the center -most pixel. 

One may, however, designate any pixel. ToupSky signals the pix el to be changed 

by putting a box around it. Choose the X and Y Offset  spin buttons to apply 

New•••:  Click to create a new filter kernel. The Edit Kernel  dialog will appear. The 

functions of the dialog are the same way as the dialog fo r Edit••• described above), 

with the exception that the file name for the new kernel file  must be provided. 

Delete: Click to delete the selected filter kernel file. 

Options: The choices in this group box will vary depending upon t he kind of selected 

filter. 

13.4  Image Stacking•••    

The image-stacking method is a form of speckle imaging comm only used for obtaining 

high quality images from a number of short exposures with var ying image shifts. It has 

been used in astronomy for several decades, and is the basis for the image stabilization 

feature on some cameras. The method involves calculation of the d ifferential shifts of 

the images. This is easily accomplished in astronomical images since th ey can be 

aligned with the stars. Once the images have aligned, they a re averaged together. It is 

a basic principle of statistics that variation in a sample ca n be reduced by averaging 

together the individual values. In fact, when using an avera ge, the signal-to-noise ratio 

should be increased by a factor of the square root of the n umber of images. 

Image stacking can also be used for biological microscope image a nd florescent 

microscope image to increase the image SNR and dynamical ranges; th is is why we 

introduce image stacking into ToupSky. 

ToupSky Image Stacking  introduced advanced image matching techniques for rotated, 

shifted and scaled images. The user can record a short video to g et a high quality 

stacked image at ease without considering the image rotation, shifti ng and scaling 

between a series of images in the video. The steps of Image Stacking are described as 

below: 
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1�Ê Choose Processing>Image Stacking •••  menu, a Windows Open  dialog will pop up 

as shown below; 

 

2�Ê Choose the right video file recorded before in the Open  dialog, here we can open 

“test.avi”  for demonstration, click Open  to open the avi file; 

3�Ê Then an Image Stacking  dialog will pop up to show the progress of the each image’ s 

stacking progress.  

 

4�Ê If Cancel  is pressed, the Image Stacking  will be canceled. After the stacking is 

finished, a stacked image will be displayed in a new window for further application. 

The final image is shown as below. One can find the stacked i mage signal to noise 

ratio is greatly improved. From the stacked image has some black  edges, this is 

because the images in the video is moved and in the stackin g process, ToupSky 

will added 0 to the image area that has no corresponding p ixel in the reference 

image (we choose the first image in the video file as the refer ence image). 
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Note : a. ToupSky support wmv �Èasf �Èavi �Èmp4 �Èm4v �È3gp �È3g2 �È3gp2 �È3gpp �Èmov �È

mkv �Èflv �Èrm �Èrmvb for Image Stacking  operation; b) In the Image Stacking  process, 

ToupSky takes the first frame as the reference image, this mean s the first frame is very 

important and should be assure the first frame to be the righ t image scene and the 

subsequent frames have a greater overlap region with the first  frame. 

13.1  Range •••   Shift+R 

The Process>Range •••  command allows set the intensity levels of the image to increase  

the contrast and enhance the display in low-light situatio ns. Choose the Range  

command to open the Range  dialog. 

Two vertical markers  show the upper  and lower  limits of the intensity levels. These 

markers can be moved with mouse through the drag and drop method.  For a color 

image, the histogram will reflect the red , green , and blue  values with corresponding 

colors lines. 

 

Two Edit  controls indicate the values of the intensity levels. Choose the spin buttons to 

increase or decrease these values. All values between 0 and the lower li mit will be black 

and all values between the upper limit and the upper end of t he scale will be white. 

These two edit control values corresponding to the two vertical markers  show the upper  

and lower  limits of the intensity levels. Defaults are o and 255 respect ively. 

Reset: The Reset  button allows Reset  the black and white levels to the high and low 

ends of the dynamic Range . 

Best Fit: The  Best Fit  button automatically sets the intensity levels to the Best Fit . 

Best Fit  instructs ToupSky to optimize the brightness and contrast va lues for the 

particular image. 

Invert: The Invert  button reverses the color of the image. 

Update: Update  will refresh the display Range  with the most current image 
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information. 

13.1  Binary •••   Shift+B 

Binary  is a kind of gray level process. If the gray of the pixel is greater than the given 

threshold, the pixel's color will be changed into white. Otherwi se, the pixel's color will 

be changed into black. Although the process may lose some i nformation, it is an 

important step of other processes. 

 

The curve on the Binary  dialog shows the gray distribution of the image. 

The Line  in the dialog indicates the threshold value. Drag the line to change the 

threshold, or change the value in the Line  position edit  box (in the top left corner of the 

dialog) to move the Line . 

The Line  position edit  box shows the current position value of the Line ; Modify the value 

will move the Line  at the same time; 

Click the " Best Fit " button to apply the auto threshold process to the image. It uses an 

automatic threshold to make the image Binary .
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13.1  Pseudo Color •••  

Note : Image must be in Gray Scale .  

Choose the Pseudo Color  command to "colorize" the active monochromatic image. This 

is used to highlight certain features in a gray scale image s uch as display all densities 

above a certain point in red, or, the imaging device record ed thermal information, all 

temperatures below a certain point can be revealed in blue color. 

 

When Pseudo Color  a monochromatic image, a special palette need to be build with 

which the monochromatic image is displayed. Pseudo Color ing an image does not 

modify the pixels' values in image bitmap (it does not conv ert image to true color or 

palette). It simply associates a Pseudo Color  palette with the image that interprets the 

gray-level values in the image as color.  

Pseudo Colored images are very similar in structure to palett e class images, but they 

differ in a couple of important ways. First, the pixels' values in a Pseudo Color ed image 

actually represent continuous-tone intensity information, wher eas a palette image's 

pixels carry no intensity significance. Secondly, a palette image in cludes a palette table 

that is actually part of the image file.  

The colors used to map the gray values can be selected. The but tons at 

each end of the color strip s (  or  ) will bring up the color 

dialog separately, which allows select the start and end colors of the 

range. 

 

13.1  Surface Plot •••  

The Process>Surface Plot •••  (or 3-D Plot) tool creates a 3-D representation of the 

intensity of an image. When choosing the Surface Plot  command, keep in mind that 

X=image width and Y=image height, and Z=pixel gray value.  

In the viewpoint window, the elevation  and rotation  of the image can be adjusted by 
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dragging the mouse on the image. 

 

Position Solid : The left edit control indicates the relative position of the entire image in 

the viewpoint window, whose default value is 0.5. The rig ht edit control indicates the 

relative height of the display of the Z scale, whose default valu e is 1. 

Reset : Set the Position Solid 's two edit controls to their default values. 

Image Background Color : Choose this command to display a color dialog where one 

can adjust the background color of the viewpoint window.  

Capture : Capture  the active image in the viewpoint window as a new image. 

Color Table : Select the colors to map the gray values found in the surfa ce plot. The 

button at each end of the Color Table  brings up the color dialog, which allows select the 

start and end colors of the range. (Please refer to Pseudo Color  for more information)
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14  Options 

14.1  Preferences •••    

There are 7 pages for the Preference  dialog. They are Record , Batch  Record , Auto 

Capture , File , Grids , Video  and Misc pages. 

14.1.1  Record Page 

The Record  page can be used for the pre-setup of the Capture>Start Record  command 

operation with no need to further specify the file directo ry, file name and file format. 

All those are specified in Options> Preferences••• >Record property page. 

 

Directory : Enter the name of the drive and directory where the new i mage will be saved. 

You may either type the path information, or use the Browse  button  to locate it 

from a standard Browse Folder  dialog; 

Name Format : The year , month , date , hour , minute  and second  or nnnn(sequence)  can 

be used as part of the file name. If more files are saved wit h in a second, a (xx)  suffix 

is attached to the end of Name Format  to avoid the possible name confliction. For the 

nnnn(sequence)  Name Format , no suffix is needed; 

File Prefix : Enter a file name prefix for Capture>Start Record  or Capture>Batch Record  

command when generating files names for video ( Capture>Start Record ) or a series of 

video ( Capture>Batch Record ). This prefix will be combined with Name Format  to form 

a final file name naming paradigm; 

File Type : In this combobox, select the format in which you want the i mage to be saved 
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(can be SER or AVI );  

Sample : The final file name is shown at the right of the Sample  label for reference; 

Show the rename file dialog : The file name can be renamed according to whether or 

not this item ’s setup . When this item is checked, a Rename  dialog will pop up after 

choosing  capture>Start Record  command or click the  button on the toolbar. The 

new name can be specified here again according to the requir ement; 

 

Limit>Time Limit(Secord(s)) : The whole time for the record; the default is 

60(1~3600s); 

Limit>Frame Limit : The number of frames to be recorded; the default is 1000(1~ 

1000000); 

When both of them are checked, the video record will be stoppe d after one of the limits 

is reached. 

14.1.2  Batch Record Page 

The Batch Record page is used for the pre-setup of the Capture> Batch Record 

command. Choosing the Options> Preferences•••> Batch Record  property page will 

invoke a dialog as shown below: 
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Number : The number of files to be recorded (2~10000, default is 10). 

Time interval (Second(s) : How long it will take to record the next video file (0 ~36000, 

default is 10); 

The other record parameter can be defined in Options> Preferences•••> Record property 

page. Please check it for detail. 

14.1.3  Auto Capture 

The Auto Capture  page is used for the setup for the Capture>Auto Capture  command. 

This can be done in Options> Preferences•••> Auto Capture  property page: 

 

Directory : Enter the name of the drive and directory where the new i mage will be saved. 

You may either type the path information, or use the Browse  button  to locate it 

from a standard Browse Folder  dialog; 

Name Format : The year , month , date , hour , minute  and second  or nnnn(sequence)  are 

used as part of the file name. If more files are saved with  in a second, a (xx)  suffix is 

attached to the end of Name Format  to avoid the possible name confliction. For the 

nnnn(sequence)  Name Format , no suffix is needed. 

File Prefix : Enter a file name prefix for Auto Capture  when generating files names for a 

series of images. This prefix will be combined with Name Format  to form a final file 

name according to the naming paradigm. 

File Type : In this combobox, select the format in which you want the i mage to be saved 
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(can be BMP, JPG, PNG, TIF, FIT); 

Sample : The final file name is shown at the right of the Sample  label for reference; 

Capture every frame : Check this item will capture every frame in the video sequence; 

Time slot(second) : Capture an image according to the time interval to (0 -100S, default 

is 6); 

Total Images : Checking Total Images  will enable its edit box. You can enter the Total 

Images  (1-9999) to be captured. ToupSky will stop the Auto Capture process 

automatically when the Total Images  are reached; 

If Total Images  is unchecked, ToupSky will capture the images continuously until  user 

choose the Capture>Stop Capture  command again to stop the Auto Capture process. 

After the Auto Capture  is started, the Capture>Auto Capture  menu will be changed to 

the Capture>Stop Capture)  menu. Choosing this command will stop the Auto Capture  

process. 

There are a variety of image format available (they are bmp , jpg , png, tif or fit ) to save 

the captured image. For example, when choosing jpg  format, the save options can be 

set in Options> Preferences•••> File  property page. If the format has options, the 

Config•••  button will be enable.  

 
Clicking the Config•••  button will pop up a dialog as bellow. Different format  has 

different options. 
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After all the parameters are set. Click OK will close the dialog and the parameters can 

be used for the Auto Capture  command with no further setup. 

 

See Options>Preference ••• >File page  for details. 

14.1.4  File Page 

One can check a file Extension  for the specified file Format  and its Abbr .(abbreviation), 

to determine whether or not it will be displayed in the Browse  window or not (The 

checked Format  can be displayed in the Browse  window). 
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Extension : Used to identify the file extension; 

Format : English full name of file formats; 

Abbr. : File Format ’s a bbreviation; 

Browse: Check/uncheck to determine whether or not the file format can be displayed 

in the Browse  window; 

Config…: To configure the image file  Save As  Option  for JPEG, Portable Network Graphics, 

Tag Image File Format, CompuServ, JPEG 2000 Standard, JPEG C odestream, GIF. For 

details, please refer to the Option  button explanation in the File>Save As ��in Sec.6.4 �� 

14.1.5  Grids Page 

Choosing the View>Grid> Setting•••  command, or choosing the Options> 

Preference>•••  command and clicking the Grids  page to realize the same function. 

Choosing the Preference>•••  command and clicking the Grids  page can set the Grid 

Style , Line Style , and Line Color  for the Grid  overlaid on the video and image window 

can also be set. 

 
Grid Style : The Grid Style  can be No Grid , Auto Grid  or Manual Grid . Default is No Grid ; 

Grid Line Style : The Line Style  for the grid can be Solid , Dash , Dot  or DashDot  et al. 

Default is Solid ; 

Grid Line Color : The color of the grid line. Default is Red (255,0,0). 

14.1.6  Video Page 
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Choose the Options>Preference  dialog and click  Video  to show the Video  page. The 

Video page is used to set Date Time  and Clarity Factor  to overlay on the video window. 

 
The Position , Background , Font Size , Font  Weight  of the  Date Time , and Clarity  Factor  

can be defined together. Their  Colors  can  be defined separately. 

Clicking the OK button and the  Date Time , and Clarity Factor will be overlaid on the 

Video  window. 

The Clarity Factor  can tell if the sample is in good focused state or not. The larger the 

Clarity Factor , the better the sample focused. 

14.1.7  Misc Page 

The Misc page is mainly used for the control of the ToupSky UI. I t mainly includes: 

1. Show the splash windows on the startup; 

2. Prevent screensaver when video preview / capture 

3.Units of temperature; 

4. Sidebars; 

5. UI Style; 

6. Language; 

7. Enable GPU accelerated image processing; 

8. Privacy; 

settings et al. They all are shown as below. 
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15  Window 
15.1  Close All 

Choosing the  Closes All  command to close all of the pictures opened or captured inside 

ToupSky frame. If you have made any modifications to the p ictures or if you have 

captured some pictures from the camera, choosing the Close All  will let you finish the 

saving operations quickly. 

 
If the above image windows exist, choosing the Window>Close All  command will bring 

up a Save Files  dialog as below: 

 

1. Clicking Yes on the Save Files  dialog will close the Video  , Browse , Image  windows 

directly that are not changed without ask anything. If th ere are newly created Image  

window, ToupSky will bring up a Save As  dialog to prompt user to enter the File name  

to save file. 
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If Save  or Cancel  is clicked in the Save As  dialog, ToupSky will return to the Save Files 

dialog to continue the next file close operation; 

2. Clicking No on Save Files  dialog will close the current image window without saving 

operation and return to the Save Files dialog to continue the next file operation; 

3. Clicking Cancel  will cancel the Save Files dialog without doing anything; 

4. Clicking Yes to All  on Save Files  dialog will always bring up a Save As  dialog to let 

you enter the File name  to save files one by one until all of the files are saved;  

5. Clicking No to All  on Save Files  dialog will close all of the image windows without 

saving them; 

6. Clicking Batch Save  on Save Files  dialog will transfer the save process to File>Batch 

Save •••  command. Please check the File>Batch Save •••  menu for details; 

Note : If you have a lot of pictures opened and have made some mod ifications on them 

and want to close them quickly without saving anything, yo u may uses this command 

and choose Step 5. All the images will be closed instantly, no  warning will be given. 

15.2  Reset Window Layout 

Choosing Window>Reset Window Layout  will reset the ToupSky window layout to the 

original one. The reset will be effective after restart. 

 

15.3  Windows •••    

Choosing the Window> Windows•••  will open a dialog box that lets you manage the 

currently opened windows. 

The dialog allows you to manage large lists of open windows by assigning them into 

groups. Let us say you have 10 windows opened, but want to  close 4 of them scattered 

through the list. 
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1.  Choose the Window>Windows •••  command; 

2. Select the windows you want to close. Hold Ctrl  or Shift  key to select more than one 

at a time. Here, 4 items are selected; 

 
3.  Click Close Window(s)  button, those 4 selected windows will be closed, leaving the 

other files or captures available for editing; 

4. User can use this command to switch to the checked window on a list by hitting 

Activate  (or "bring up" from an icon multiple windows).
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16  Help 

16.1  Help Contents    F1 

Choose the Help>Help Contents  command to load ToupSky help file. The help file is in 

Portable Document Format (PDF). 

PDF is a file format used to represent documents in a manner  independent of application 

software, hardware, and operating systems. Each PDF file encapsul ates a complete 

description of a fixed-layout flat document, including th e text, fonts, graphics, and other 

information needed to display it. In 1991, Adobe Systems co- founder John Warnock 

outlined a system called "Camelot" that evolved into PDF. 

While the PDF specification has been available free of charge sin ce at least 2001, PDF 

was originally a proprietary format controlled by Adobe. It was officially released as an 

open standard on July 1, 2008, and published by the Inter national Organization for 

Standardization as ISO 32000-1:2008. In 2008, Adobe pub lished a Public Patent 

License to ISO 32000-1 granting royalty-free rights for a ll patents owned by Adobe that 

are necessary to make, use, sell and distribute PDF compliant implem entations. 

If your computer still does not install the PDF reader, please try to download it from: 

http://www.adobe.com/downloads/  

16.2  About •••  

Display the related information about ToupSky, including  ToupSky version , Compatible , 

Built  date and its developer’s www  etc. 

 

Clicking on the URL link will direct you to the address of the application sup plier. If you 

have any problem with the camera or application, please feel free  to contact your 

supplier. 


